0

I am quite new to civicrm, but managed to get a site up and running (the instance had records etc)- somehow I managed to delete the uploads folder. so I did a fresh install of Wordpress 5.9, created a new database for civicrm and a fresh install of civicrm 5.46.0. I enter database details, installation starts, but stops with this error, you need to define CIVICRM_DSN in civicrm.settings.php, but the file doesn't exist neither does the civicrm folder in uploads. I have chmod plugins and uploads with write permissions, tried creating the folder myself, I don't know what else to do to get it working.

1 Answer 1

1

The civicrm.settings.php by default is in: /wp-content/uploads/civicrm/civicrm.settings.php

So if you deleted the uploads folder it might make sense it can not find it.

The civicrm folder in uploads contains a lot more as well.

You mentioned you did a fresh install of civicrm, that actually should have created this folder, with everything in it. So my guess is that went wrong. So, you might want to retry that.

1
  • Yes after deleting the uploads folder - I deleted everything and did a fresh install of Wordpress (with a new uploads folder) and a new install of civicrm, but it won't write to the new uploads folder. I am going to delete it all and try again. Feb 14, 2022 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.