This is a D7 site. It uses CiviGrants and has over 600 of them using lots of custom fields. I am trying to upgrade from 5.46.2 to 5.47.0. When I run the db upgrade using the update url, it freezes right at the end. If I try to run the updates via Drush, I get the error:

WD php: Error: Class 'CRM_Grant_DAO_Grant' not found in CRM_Core_PseudoConstant::get() (line 212 of [error] /var/www/dev/web/sites/all/modules/civicrm/CRM/Core/PseudoConstant.php). Error: Class 'CRM_Grant_DAO_Grant' not found in CRM_Core_PseudoConstant::get() (line 212 of /var/www/dev/web/sites/all/modules/civicrm/CRM/Core/PseudoConstant.php). Drush command terminated abnormally due to an unrecoverable error.

  • 1
    CiviGrant was moved to an extension in CiviCRM 5.47. There was a lot of testing to avoid this sort of issue but it looks like you found an issue. I would go to chat.civicrm.org, enter the ~product-maintenance channel, and point them to this question. This will get taken pretty seriously. Mar 7 at 16:34
  • Daniel -> do you have any webform civicrm and/or civicrm entity integration? Mar 7 at 22:14
  • @KarinG-SemperIT Yes, I have both Civi-Webform and Civi-Entity. I was thinking I should test the upgrade with them disabled. Mar 7 at 23:48
  • @JonG-MegaphoneTech Thanks for the advice. I will post this on chat.civicrm.org Mar 7 at 23:50
  • For Webform CiviCRM module (my team maintains that) -> download and install drupal.org/project/webform_civicrm/releases/7.x-5.8 [it's 5.47 compatible]. Mar 8 at 0:39

1 Answer 1


Can you try to apply the patch

  • Yay! That did bring back my CiviGrant Views. I applied it on a site that had already been updated so I did not test to see if the upgrade worked without crashing. I'll try that later or tomorrow. Thanks to so many people for working on this! Mar 9 at 21:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.