0

I am probably missing something glaringly obvious but I've been running in circles in the past days.

I've been unable to send emails to recipients (usual mailing, mosaico..) and after a lot of tuning the system supposedly sends the email (doesn't show any errors) but the mailing is stuck on scheduled and won't budge.

In the outbound mail I've tried the mail() and SMTP options to no avail. For the latter I added my work gmail account with its username and password. In the mail accounts settings I have two items, both on the same server with Maildir protocol and not using SSL. One is used for Email-to-activity and the other for Bounce processing.

The environment instance of civiCRM is set to production.

The FROM addresses I added were my work e-mail just to test it (it was added for SMTP settings) and a few addresses that are gmail routing addresses (it's not a "proper account" where you have a username/password but you choose the name of your e-mail and it routes into inboxes of people who are recipients of such routing address).

None of the e-mails go past the scheduled point.

I enabled the Send Scheduled Mailings in the Scheduled Jobs settings but it seems that cron jobs have not been enabled so that could possibly be the culprit? If cron jobs are the problem, can I use the mentioned routing addresses as from addresses and what should I add as SMTP settings if that's what I'm supposed to use (we use gmail for our communication). I really don't want my username/password to be associated with it.

Civi is on Wordpress 5.9.2.

5
  • Have you tried executing Send Scheduled Mailings in the Scheduled Jobs manually? Mar 11, 2022 at 11:22
  • Can you please clarify exactly what happens when you press "Save and Send Test Email" on the Administer menu » System Settings » Outbound Email screen? None of the rest of this matters if that's not working. Mar 11, 2022 at 15:46
  • @PradeepNayak, it says that the Send Scheduled Mailings (job.process_mailing) job has been executed
    – slovojed
    Mar 17, 2022 at 9:51
  • @JonG-MegaphoneTech, settings always revert to mail() as Mailer regardless of saving differently. When sent using mail() I get confirmation that the mail has been sent but nothing comes, and when using SMTP with my personal credentials (and that e-mail was added in From Email Adress) I get an error screen that the SMTP settings are incorrect saying that the "Network is unreachable". Mail was sent to a group of 3 members (2 gmail, 1 protonmail) and 1 gmail was flagged as not being on hold.
    – slovojed
    Mar 17, 2022 at 9:52
  • @slovojed Do you have root permissions on the underlying server, or is this a shared hosting situation? It sounds like you might have an outbound firewall issue, particularly with "Network is unreachable". The built-in mail() uses the server's mailer, and if that's not coming through, the server is probably unable to send mail. If you do have access to the server and can see the mail logs, it's likely there are clues there. If you have SSH access, a tool like swaks can help troubleshoot too. Mar 17, 2022 at 21:22

1 Answer 1

0

If you haven't set up a cron job then none of the shceduled jobs you enabled are going to run automatically, so that is definitely necessary. Pradeeps suggestion is a quick way to check if this will solve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.