0

I have a similar issue of the 2017 post first CiviCRM request of each session takes 4 minutes, afterwards works fine

I have a fresh virtual server in a university saas, with wordpress 5.9.2, php 7.4, no extension, civicrm. The first time after logging, if i click on civcrm, i have to wait 4 minutes before i can acces the menus. I tried everything (anothers virtual machines, with or without databases, change php version, etc..). I just found the other post today. No luck, i changed in civicrm.settings.php the CICICRM_CMSDIR CIVICRM_CMSDIR', '/home/entetu/htdocs/wp-content/') and no change on my local server, netcat on ports 80 and 443 are open So i need to disable checks but i don't know how to do it. Can somone give me a hand on this, please ?

1
  • This does seem like it's the same cause as the other post. Turn off version checks under Administer - System Settings - Scheduled Jobs. And then also the other setting it mentions in civicrm.settings.php - civicrm.stackexchange.com/a/24453/181
    – Demerit
    Mar 30, 2022 at 16:34

1 Answer 1

0

I turned off Scheduled jobs, but no effect. now, i've got a message : The CiviCRM public extensions directory at https://civicrm.org/extdir/ver=5.47.2|cms=WordPress could not be contacted - please check your webserver can make external HTTP requests. Contact your site administrator for assistance.

In civicrm.settings.php i uncommented // $civicrm_setting['domain']['ext_repo_url'] = false; and the access is immediate. So the problem is the extensions.

I work behind a proxy server, so there must be a connection problem to reach the external extensions. I found in https://github.com/civicrm/civicrm-cxn-rpc/blob/master/doc/proxy.md define('CIVICRM_CXN_VIA', 'proxy_address:PORT');

a way to indicate a proxy to civicrm but it didn't work. Any clue for another way to fix proxy with Civicrm ?

2
  • Can you access other external sites from within your network without a proxy? On one site it was finding an IPv6 address and attempting to use that but blocked by the internal network.
    – Aidan
    Apr 8, 2022 at 17:57
  • Welcome to Stack Exchange! To preserve the usefulness of this site to folks with the same question as you, you shouldn't put non-answers in the "Answers" section. Please edit the original question to include this information and delete this answer? Apr 15, 2022 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.