There are a lot of questions here on the message "Cron not running", but I have failed to find one that actually describes how CiviCRM keeps track of this, which might help explaining what we see in our installation.

We have a cron job that runs the "execute" job every five minutes:

EXECUTE_ALL = -e Job -a execute
# cronjob for execution of all CiviCRM jobs
# m h dom mon dow command
*/5 * * * *   cd $CIVI_ROOT; $PHP bin/cli.php -j -s $CIVISITE -u $CIVIUSER -p $CIVIPASS $EXECUTE_ALL

And Civi reports that each job has run successfully. But we still have this:

enter image description here

Civi´s job "control" thinks the last run was at 02:26 but the Bounce fetcher was last run at 11:10.

We are at UTC+1, Joomla 3.10.4, CiviCRM 5.47.3, Ubuntu 20.04, mysql Ver 15.1 Distrib 10.3.34-MariaDB.

The timestamps in the _civicrm_job_log database table is consistent with our actual time.

Can I still be seeing some timezone issue?

2 Answers 2


After googling and searching a bit more, it looks like CiviCRM considers the Update Check job as the heartbeat that it monitors.

And as others have noted in other questions and answers on this topic, it needs to run at least hourly for CiviCRM to consider the cron jobs to be functional.

So, if you have this warning, check how often your "CiviCRM Update Check" job is run at least hourly (as is in fact recommended).


I too have a similar problem. Cron is most certainly running, but our WordPress instance insists that Cron is not. I changed our update Check job from daily to hourly, as suggested above, but this didn't alter anything.

To be clear, for us, CiviCRM does not report that jobs are successful. CiviCRM jobs simply never happen.

As you can imagine I am keen for insights. Each time we do a newsletter mailout or an announcement, I have to force the job to execute manually (Settings > Scheduled Jobs > pick the one I want > Execute now).

If more appropriate, I can compose a separate question for my case, but the general symptoms seem to be quite similar to those described above.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.