1

CiviCRM v5.48.2, WordPress v 5.9.3

I have a cron running as follows:

/usr/local/bin/php /home/xxxxxx/public_html/wp-content/plugins/civicrm/civicrm/bin/cli.php -u xxxxxx -p xxxxxxx -e Job -a execute

Entity: Job Action: mail_report
Summary Starting execution of Mail Reports

Details

Parameters raw (from db settings): 
instanceId=xxxx
format=PDF

Parameters parsed (and passed to API method): 
a:3:{s:7:"version";i:3;s:10:"instanceId";s:4:"xxxx";s:6:"format";s:3:"PDF";}

Full message: 
Starting execution of Mail Reports
2022-05-03 23:35:06 Mail Reports    
Entity: Job Action: mail_report

Summary Finished execution of Mail Reports with result: Failure, Error message: is not of type String
4
  • Anything in the civicrm log?
    – Aidan
    Commented May 5, 2022 at 8:35
  • Too long to add. Seems to be starting here: May 04 23:18:27 [info] inactive contribution page access attempted - page number 2 May 04 23:18:27 [error] $Fatal Error Details = array:3 [ "message" => "The page you requested is currently unavailable." "code" => null "exception" => CRM_Contribute_Exception_InactiveContributionPageException {#9799 -id: 2 Commented May 5, 2022 at 16:40
  • Here is the entire error which tends to repeat itself: pastebin.com/embed_iframe/BncdZcrF Commented May 5, 2022 at 16:52
  • It appears that the mailings are now being sent: Entity: Job Action: process_mailing Summary Finished execution of Send Scheduled Mailings with result: Success (a:1:{s:9:"processed";i:0;}) Details Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;} Full message: Finished execution of Send Scheduled Mailings with result: Success (a:1:{s:9:"processed";i:0;}) Commented May 5, 2022 at 17:07

2 Answers 2

2

Apparently what fixed this was that I had to obtain the InstanceId that I pulled by selecting one of the Mailing Reports (I went to Reports - Mailing Reports - and then chose the Summary. In the browser I identified the number of the report which came after "instance%XXXX" and used the "XXXX" as the number. I entered the number by going to Admin - System Settings - Scheduled Jobs and it gave me all of the reports from which I selected Mailing Reports and then clicked the edit button which allowed me to edit both the InstanceId and the format. I selected "PDF" for the format. Not sure if the format is right, but the job runs now.

1
  • We're having the same issue. However, when I bring up the Summary Report as in your description above, I get no results. Is there another way to get the instanceId? Commented Dec 14, 2022 at 18:06
1

Encountering a similar problem, with similar logs, except that my instance ID is set to "[ID of report instance]," which had, evidently always worked before.

At the moment, I don't even have a mailing to run reports on, though we're about to do a big one and I need to make sure this is working.

Parameters parsed (and passed to API method): a:3:{s:7:"version";i:3;s:10:"instanceId";s:23:"[ID of report instance]";s:6:"format";s:3:"pdf";}

Full message: Finished execution of Mail Reports with result: Failure, Error message: is not of type String

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.