2

Currently running Civi 5.49.1 but I've been seeing this behaviour for a little while now. I've got Civi set up to apply VAT (sales tax) and issue invoices, which go out with event registration confirmation emails. All good.

What used to happen as far as I can recall is that if the event was free, then no invoice was created or sent. Ideal.

However what I'm seeing is that participants are being sent confirmation emails with an attached file called 'invoice.pdf' which is blank. Not good.

Before I log this as an issue in Gitlab, is there a recent change in the settings/config around invoicing that I'm missing, or is this a bug that others are seeing?

6
  • Noticed a similar thing when registering users via the back end, non paid event and sending a confirmation email with tax enabled. Blank invoice.pdf attached to the email. Have you logged a bug report by any chance or resolved the issue?
    – Adam
    Jun 16, 2022 at 10:49
  • just putting a note for myself that we also had a report of this but have not solved yet but the example we were told about was not a free event (but we didn't get all the evidence sent on to us). r26419
    – petednz - fuzion
    Jun 16, 2022 at 19:58
  • 1
    more info - I can ONLY replicate this if I do an 'offline' registration for someone. if i do an 'online' one I get a PDF called confirmation.pdf which mirrors what is in the email. if i do offline then i get a 1kb pdf that is completely blank called invoice.pdf. hopefully have a fix early next week but what is better? A/ No pdf? or B/ a non-blank PDF that, as per the online one, is called confirmation.pdf and just mirrors what is in the email. suspect A/ is easier
    – petednz - fuzion
    Aug 10, 2022 at 23:56
  • 1
    note - i was misled by a client reporting this was happening when folk were registering, but turns out they were being registered via backend!
    – petednz - fuzion
    Aug 10, 2022 at 23:56
  • 1
    I think this is fixed in 5.53 - see github.com/civicrm/civicrm-core/pull/24065
    – Demerit
    Aug 12, 2022 at 18:16

1 Answer 1

0

This has been fixed now with this https://github.com/civicrm/civicrm-core/pull/24065

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.