0

I recently upgraded to CiviCRM 5.5 on an Apache2 server with PHP 7.4

Now, when I attempt to open the CiviCRM status page I get an HTTP error 500, and this also happens when trying to create a new mailing (either Mosaico or traditional)

I think also that Civi Cron is erroring, as every 5 minutes in Apache2 error.log I see:

[Fri Jun 03 19:05:02.797134 2022] [php7:error] [pid 2718] [client 95.172.20.13:54108] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /var/www/XXX/wp-content/plugins/civicrm/civicrm/Civi/Token/Event/TokenRegisterEvent.php on line 67
[Fri Jun 03 19:05:02.797939 2022] [php7:error] [pid 2718] [client 95.172.20.13:54108] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /var/www/XXX/wp-includes/class-wp-fatal-error-handler.php on line 73
[Fri Jun 03 19:05:02.798448 2022] [php7:error] [pid 2718] [client 95.172.20.13:54108] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /var/www/XXX/wp-includes/plugin.php on line 189

(XXX not the real folder name) I have tried enabling CiviCRM logging but it doesn't reveal anything more useful. I've tried enabling PHP error notices but am still seeing a 'friendly' HTTP error 500 in Chrome.

I've also tried temporarily disabling Mosaico.

Would really appreciate any assistance in debugging this further, thank you!

1 Answer 1

2

Try running the extension upgrades. Go to the Manage Extensions page, and it should display a notice to upgrade extensions.

Alternatively, try going to https://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fextensions&reset=1 (replace example.org with your website).

I think this is specific to CiviCRM 5.50, when SearchKit is enabled. There are discussions here on how to avoid this problem in the future.

1
  • Thank you, this pointed me to the problem-a custom extension. Once disabled, all is fine! Jun 3, 2022 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.