Upgraded from something pre new form builder stuff to 5.49.3. Now in Mosaico the top block, header, looks fine in the drag and drop stuff but when you view it in html, instead of just see the the unsubscribe and the view in your browser at the top you also see the full mailing address and civicrm/mailing/optout?reset=1&jid=&qid=&h=fakehash above the links.

I've tried to create a new template, same thing.

In the generating HTML to either email or to just view, it's adding in the organization snail mail address from admin organization address and contact info. (I tried changing that info just to verify that's where it's coming from).


1 Answer 1


Thanks to petednz who pointed to a solution in chat.

The problem was fixed in my case by going to Mailings => Headers, Footers, and Automated Messages and looking at all the headers and footers that were marked default. In my case, the first one marked default was the problem. By editing it and unchecking default the problem went away.

Note: it only fixed it on new mailings and on any new mailing copied from an old mailing created before the update.

Edit - this didn't really fix it for mailings copied from old mailings: When the mailing was sent it errored saying it was missing domain.address, action.OptOutURL or action.UnsubscribeURL. I ended up adding a footer id in the message table for that mailing. When creating a new mailing from a template it worked. There is more solutions in the same question comment link above,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.