0

I'm brand new to checksums. This problem was reported several years ago. Personalised link using checksum tokens leads to empty page I have the same symptom: the checksum URL points to a page with the name of the profile repeated 10 times but none of the profile fields are displayed. The problem reported several years ago turned out to be a bad URL. I've checked my URL with the CiviCRM documentation which shows this profile for Wordpress (without clean URLs); http://example.org/?civiwp=CiviCRM&q=civicrm/profile/edit&reset=1&gid=IDNUMBER&{contact.checksum}&id={contact.contact_id}. I replaced IDNUMBER with the number of my profile. I tested using the number of an alternate profile with the same result: the URL points to a page with the name of the alternate profile (repeated 10 times) but none of the fields displayed. CiviCRM 5.48.0 on Wordpress Version 6.0 (without clean URLs)

3
  • might be worth comparing with wpmaster.demo.civicrm.org in case it works as expected on that site which then may point towards some config / path issue specific to yours
    – petednz - fuzion
    Jun 11, 2022 at 23:12
  • 1
    When I use the wpmaster.demo.civicrm.org test facility I can reproduce the error I'm having if I use the profile for Wordpress sites without clean URLs. But if I use the profile for WP sites with clean URLs the profile displays correctly. Unfortunately, our museum site operates without clean URLs so I haven't isolated the problem. (Thanks for the suggestion to try that demo site. I hadn't realized that it could be used for testing as well as demos.) Jun 12, 2022 at 20:55
  • 1
    Clarifying my earlier comment: our webmaster just advised me thatour Wordpress site has the code enabled for clean URLs but the we haven't done the housekeeping to clean up the URLs. Jun 13, 2022 at 14:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.