2

I have created a Member Sign-Up form that goes to a Contribution page with three price sets (one is always hidden with JS, so two appear). Under the Contribution Page's settings, "Use a confirmation page?" is checked. When valid input is submitted, the Confirmation page that comes up next has no visible content. In the HTML a form with the id "Confirm" is shown, but it has only hidden inputs and no submit button.

Does anyone know why this is happening? How can I get a normal confirmation page to appear?

This is testable at http://aplddemo.wpengine.com/sign-up/?type=student

To make this issue even more unusual, after creating a different (test) Contribution page and completing a transaction on that, the original confirmation page began working. My immediate issue is solved, but I'm still curious why this happened and what is to prevent it from happening again.

UPDATE - September 1

This issue reappeared. This time I added ini_set('display_errors', true); to my plugin, and see errors like the following:

Warning: include(/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/templates_c/en_US//%%3D/3D1/3D13F2BA%%Main.tpl.php): failed to open stream: No such file or directory in /nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/civicrm/civicrm/packages/Smarty/Smarty.class.php on line 1907

Warning: include(): Failed opening '/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/templates_c/en_US//%%3D/3D1/3D13F2BA%%Main.tpl.php' for inclusion (include_path='/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/custom_ext/com.osseed.eventcalendar-1.1/:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/custom_ext/ca.bidon.civiexportexcel/:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/custom_ext/nz.co.fuzion.extendedreport/:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/custom_ext/co.johnwebster.apld/:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/files/civicrm/custom_ext/org.civicrm.module.cividiscount/:.:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/civicrm/civicrm:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/civicrm/civicrm/packages:.:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/civicrm/civicrm/:/nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/civicrm/civicrm//packages:.:/usr/sha in /nas/wp/www/cluster-40204/aplddemo/wp-content/plugins/civicrm/civicrm/packages/Smarty/Smarty.class.php on line 1907

I thought it might be a caching issue, so I went to Administer > System Settings > Cleanup Caches and Update Paths, but clicking the "Cleanup Caches" button doesn't affect the error. The issue changes periodically. Sometimes parts of the form appear, with an error about the missing compiled Smarty template where the price field should be. I haven't been able to connect the change in the error's behavior/message to any other changes on the site. They seem to happen on their own.

  • I am getting the following Error while submitting the form --------- Sorry but we are not able to provide this at the moment. '2592' is not a valid option for field custom_205 – Ramesh - ARTECH Consultancy Jul 27 '15 at 13:27
  • Thanks for taking a look. custom_205 is the state field. It looks like you selected a UK state, which has no local chapters and caused a no results error. I'll add a fix for that. In the meantime, would you be willing to test using a US state? – restouffer Jul 27 '15 at 14:41
  • Sorry i tried but still getting the same error even for US - Please set the custom field to accept null value – Ramesh - ARTECH Consultancy Jul 27 '15 at 15:00
  • If you still have that page open in your browser, try refreshing it. I added a try block around the API query that was throwing that error message. – restouffer Jul 27 '15 at 15:03
  • please change to default theme and please try again – Ramesh - ARTECH Consultancy Jul 27 '15 at 15:19
1

After a long investigation, this seems to have been a hosting issue. For whatever reason, the rename operation in civicrm/packages/Smarty/internals/core.write_file.php was not occurring, possibly because the temporary files were created with 600 permissions. This only occurred when the templates were accessed by a front-end user. Templates accessed through the admin section were able to rename their temporary files.

Our hosting provider was unable to find a solution. We eventually migrated the site to Pantheon.io, and everything appears to be working well there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.