1

Has anyone managed to get CiviCRM installed on a LEMP + Backdrop CMS? I have it installed but the screen has nothing actionable. Logs show nothing useful. Is there some nginx config magic required? View Details and manage alerts fails

3 Answers 3

1

The answer is: Only install it on PHP 8.0. 8.1 is too new for CiviCRM, although Backdrop is happy with it. Also, after installing, there is still no easy way back to CiviCRM config. Add /index.php?q=civicrm/admin&reset=1 to your domain URL to get there.

1
  • There is still something wrong from fresh installation, where the images for eg up/down arrow are trying to be picked from the $domain.$civicrm_root when $civicrm_root is from the settings file at backdrop root now, and yet is filesystem specific. So will have /var/www/blah blah in it. Doesn't appear that CiviCRM is ready for Backdrop yet!
    – Onyx
    Jul 12, 2022 at 10:04
1

Menu bar is missing

Try taking a look here; this forum seems to be detailing what happened in your screenshot. What worked for me was changing the url as defined in /var/www/yoursite/sites/default/civicrm.settings.php from example.com to the actual local IP I was using

I changed

if (!defined('CIVICRM_UF_BASEURL')) { define( 'CIVICRM_UF_BASEURL' , 'http://example.com/'); }

to

if (!defined('CIVICRM_UF_BASEURL')) { define( 'CIVICRM_UF_BASEURL' , 'http://192.168.1.100/'); }

0

As of Feb/2023 I have a "latest version" CiviCRM PHP 8.0.20 install that is is 90% working on "latest version" Backdrop... some PHP8 errors prevent some configuration screens from saving... and if I turn on error debugging a LOT of pages are littered with PHP8 warnings.

A LOT of problems with stuff like Warning: Trying to access array offset on value of type int in include() (line 71 of /var/www/backdrop/files/civicrm/templates_c/en_US/%%B8/B83/B8372ABF%%CaseDashboard.tpl.php).

and errors like TypeError: array_merge(): Argument #1 must be of type array, null given in array_merge() (line 48 of /var/www/backdrop/modules/civicrm/backdrop/modules/civicrm_rules/civicrm_rules.module).

very much work-in-progress

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.