0

I have been trying to update versions, and have been hitting errors

I have stepped back and step through versions and the issue appears at 5.48.x update

UPDATE civicrm_queue SET runner = "task" WHERE is_autorun = 1 [nativecode=1054 ** Unknown column 'is_autorun' in 'where clause']

I have searched but not found a similar issue. How can I get past this?

Error: Convert "is_autorun" to "runner"]

Error Field Error Value Type DB_Error Code -19 Message DB Error: no such field Mode 16 UserInfo UPDATE civicrm_queue SET runner = "task" WHERE is_autorun = 1 [nativecode=1054 ** Unknown column 'is_autorun' in 'where clause'] DebugInfo UPDATE civicrm_queue SET runner = "task" WHERE is_autorun = 1 [nativecode=1054 ** Unknown column 'is_autorun' in 'where clause'] PEAR_Exception: DB Error: no such field in /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/pear-core-minimal/src/PEAR.php on line 922

  • DB_Error: DB Error: no such field in unknown on line unknown Exception trace

Function Location

0 CRM_Core_Error::exceptionHandler(Object(DB_Error)) /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/pear-core-minimal/src/PEAR.php:922 1 PEAR_Error->__construct('DB Error: no suc…', -19, 16, Array, 'UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/db/DB.php:997 2 DB_Error->__construct(-19, 16, Array, 'UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/pear-core-minimal/src/PEAR.php:575 3 PEAR::_raiseError(Object(DB_mysqli), null, -19, 16, Array, 'UPDATE civicrm_q…', 'DB_Error', true) /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/pear-core-minimal/src/PEAR.php:223 4 PEAR->__call('raiseError', Array) /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/db/DB/common.php:1928 5 DB_common->raiseError(-19, null, null, 'UPDATE civicrm_q…', '1054 ** Unknown …') /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/db/DB/mysqli.php:936 6 DB_mysqli->mysqliRaiseError() /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/db/DB/mysqli.php:406 7 DB_mysqli->simpleQuery('UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/vendor/pear/db/DB/common.php:1234 8 DB_common->query('UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/packages/DB/DataObject.php:2696 9 DB_DataObject->_query('UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/packages/DB/DataObject.php:1829 10 DB_DataObject->query('UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Core/DAO.php:468 11 CRM_Core_DAO->query('UPDATE civicrm_q…', true) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Core/DAO.php:1633 12 CRM_Core_DAO::executeQuery('UPDATE civicrm_q…') /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Incremental/php/FiveFortyEight.php:107 13 CRM_Upgrade_Incremental_php_FiveFortyEight::convertAutorun(Object(CRM_Queue_TaskContext)) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Queue/Task.php:73 14 CRM_Queue_Task->run(Object(CRM_Queue_TaskContext)) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Queue/Runner.php:215 15 CRM_Queue_Runner->runNext(true) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php:36 16 CRM_Queue_Page_AJAX::{closure}() /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Queue/ErrorPolicy.php:89 17 CRM_Queue_ErrorPolicy->call(Object(Closure)) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php:38 18 CRM_Queue_Page_AJAX::runNext() /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:285 19 CRM_Core_Invoke::runItem(Array) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:69 20 CRM_Core_Invoke::_invoke(Array) /var/www/html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:36 21 CRM_Core_Invoke::invoke(Array) /var/www/html/wp-content/plugins/civicrm/civicrm.php:1199 22 CiviCRM_For_WordPress->invoke('') /var/www/html/wp-includes/class-wp-hook.php:307 23 WP_Hook->apply_filters('', Array) /var/www/html/wp-includes/class-wp-hook.php:331 24 WP_Hook->do_action(Array) /var/www/html/wp-includes/plugin.php:476 25 do_action('toplevel_page_Ci…') /var/www/html/wp-admin/admin.php:259

1 Answer 1

0

This can happen if you try to re-run through the 5.48 part of the import and didn't do a complete drop of the database before restoring from backup.

This might be the same as Error updating to civicrm 5.50.3 / Drupal 7.9

See also https://lab.civicrm.org/dev/core/-/issues/3504

2
  • I think this is dues to a failed update. I will try stepping back. Aug 3, 2022 at 17:44
  • OK so the update breaks because of this Extended Reports. civicrm.stackexchange.com/questions/41445/… Now past that - but upgrade to 5.51.2 runs but then looses all my custom reports from templates, and the custom reports dont work either. CiviCRM is really hard to upgrade and keep up to date, to the point where it is getting silly. This is my second day on just trying to get updated and the old version isn't that old. The LTS version tells you to apply patches that simply are not available - dooh Aug 4, 2022 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.