1

my Community Builder registration process seems to have started failing since I updated CiviCRM recently.

Fatal error: Cannot redeclare GuzzleHttp\describe_type() (previously declared in [DOCROOT]/libraries/CBLib/GuzzleHttp/functions.php:14) in [DOCROOT]/administrator/components/com_civicrm/civicrm/vendor/guzzlehttp/guzzle/src/functions.php on line 41

I guess there are two versions of GuzzleHttp conflicting but I'm not sure how I go about resolving this. This maybe isn't specifically a CiviCRM problem, but I'd very much appreciate some guidance on how to troubleshoot this!

Joomla 3.10.10 CiviCRM 5.50.2 Community Builder 2.7.3

Thanks!

1 Answer 1

1

These links are for drupal and wordpress but it's the same type of problem. There isn't a good solution available though.

In this specific case, my guess is that community builder is using guzzle 7 (the source code for community builder doesn't seem available online to check???). If that's true, then since civi supports guzzle 7 but just ships with guzzle 6, what you can try is go into the civicrm plugin folder and run composer require guzzlehttp/guzzle:'^7' so that they end up with the same version. If something goes wrong just composer require guzzlehttp/guzzle:'^6.3' to restore the old guzzle for civi.

5
  • Thanks for the assistance, I'll check with the developers on Community Builder.
    – minbori
    Aug 7, 2022 at 12:33
  • So the Community Builder developers have confirmed they're using Guzzle 7, so I will need to change the version in Civi. Please forgive a potentially stupid question, but I have very limited experience with Composer. This CiviCRM instance was installed via the Joomla installer, and I've never managed it with Composer. Can I set up composer on an already installed Civi? If so, which is the correct plugin folder to use?
    – minbori
    Aug 9, 2022 at 9:42
  • This really is a separate question, so I've made a separate post :-) civicrm.stackexchange.com/questions/42429/…
    – minbori
    Aug 9, 2022 at 10:13
  • Just thought I'd report back -- running the composer require to change the guzzle version is working. Thanks again for the help!
    – minbori
    Aug 10, 2022 at 15:30
  • Great. Glad it's working.
    – Demerit
    Aug 10, 2022 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.