0

I upgraded to 5.52.0. The last step was to reset the database. I got an error message - " Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: syntax error"

I contacted the admin and he could find nothing wrong.

Now on

../wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fa%2F#/status

it says " New codebase version detected. You must visit upgrade screen to upgrade the database."

but at the bottom of each page that usually shows red if there is a problem it now shows: Powered by CiviCRM 5.52.0. System Status: Ok CiviCRM is openly available under the GNU AGPL License.

I retried resetting the database and got the same results.

I have not been able to find any civicrm features that I use that do not work.

Any suggestions?

2 Answers 2

0

I would suggest checking the CiviCRM logs for the error to get a more detailed explanation of what happened. I would also suggest the 5.52.2 patch update, in case there were any regressions.

I am assuming that you made a backup of your CiviCRM database before running this update (though this was 6 days ago), it may be worth restoring the backup and running the update again if that is possible.

0

I compared the mysql tables on a site that had 5.52.0 running without having a message to upgrade the database with the tables on the site that said that the database needed upgrade. I found 5 tables that had zero records on the good site that were not in the other site. I added the missing tables and now the site no longer says the database needs to be undated. Here are the tables that were missing: civicrm_queue civicrm_search_display civicrm_search_segment civicrm_translation civicrm_user_job

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.