0

We have Civi running on a WordPress v6 site The server runs plesk AlmaLinux 8.6 (Sky Tiger)

The website has been updating Civi fine via the server toolkit upto Civi 5.38 then any further updates including the most recent version have caused errors on the site even when running the upgrade manually on the site itself (downgrading/restoring back to the previous version removes the errors)

The errors seem related to it not seeing some of the extensions after the upgrade (screenshot attached)

The extensions mentioned, in the backend of WordPress all have folders in wp-content/plugins/civicrm/civicrm/ext

When checking system settings > directories - The extensions directory is set as [civicrm.files]/ext/ which the full path for is wp-content/uploads/civicrm/ext (different to the above)

As far as i'm aware this is how it's always been since the default config but the contents of the later ext folder on the paths window is currently blank in the backend, again the site has been working fine like this until the latest versions.

We have a staging version of the site we have copied for testing, and as a test have copied the contents of the folder where the extensions are into the folder specified in the upload directories and they started working again, then as another test changed the upload directories path from [civicrm.files]/ext/ to [civicrm.root]/ext/ which should point to where they were originally stored but then we get the same errors again

Any idea what the best way to resolve this please, although it seems to have intially got rid of the errors, trying to install any new extensions a new error appears of "DB Error: no such table"

(screenshots attached)enter image description here

4
  • You likely already have done this, but have you tried reloading the resource urls (load page and click save) and clearing the cache? After, you can also make sure the extension resource url is correct by clicking the ? and checking the url. You can also change the portable paths to absolute paths and see if that fixes things. e.g. CiviCRM resource URL can be example.org/wp-content/plugins/civicrm/civicrm or [civicrm.root]/
    – themak
    Commented Aug 18, 2022 at 17:20
  • Also, since this is wordpress - don't forget to load the permalinks page. Sometimes that is all it takes to fix an issue.
    – themak
    Commented Aug 18, 2022 at 17:33
  • Hi - thanks for your input - i've tried reloading the resource urls but it's still the same - I don't understand how on the exisiting working site (pre upgrade) everything was/is working fine with the extensions yet the resource url on that screen points at wp-content/uploads/civicrm/ext which is empty in the file system.... but there are folders for all the working extensions in wp-content/plugins/civicrm/civicrm/ext - any idea to explain that? Thanks
    – Cirrus
    Commented Sep 2, 2022 at 15:24
  • Permalink is not resource URLs - its wordpress permalinks. WordPress dashboard, go to Settings → Permalinks Screen
    – themak
    Commented Sep 6, 2022 at 19:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.