0
  • New Server: Intel Xeon-E2388G 3.2, with 64GB RAM and 2 1TB nvme on soft raid running ubuntu server
  • Database Server: 10.4.24-MariaDB-1:10.4.24+maria~focal
  • PHP 7.4.30, Memory Limit 512MB
  • Drupal 9.4.5, Standard Install
  • CiviCRM 5.52.2 Separate database with all permissions on Drupal and CiviCRM DBs and SUPER
  • en_GB localisation files installed after cli installation
  • No warnings at all on Drupal Status Report

Installed clean installation on the above, composer Drupal, composer CiviCRM as per CLI installer guide. Visiting the /civicrm page for the first time, seen permissions problem but fixed this on /sites/default/files/civicrm/... Refreshed with the problem text gone. Nothing displaying, other than the civicrm footer. No CiviCRM pages at all.

Followed the troubleshooting steps - caches, menu etc. Log file contains the following:

Aug 19 03:12:28  [error] $Fatal Error Details = Array
(
    [callback] => Array
        (
            [0] => CRM_Core_Error
            [1] => exceptionHandler
        )

[code] => -18
[message] => DB Error: no such table
[mode] => 16
[debug_info] => SELECT `a`.`id` AS `id`, `a`.`name` AS `name`, `a`.`label` AS `label`, 

`a`.`description` AS `description`, `a`.`entity_name` AS `entity_name`, `a`.`items` AS `items`
FROM  a
ORDER BY `label` ASC
 [nativecode=1146 ** Table 'civicrmdb.a' doesn't exist]
    [type] => DB_Error
    [user_info] => SELECT `a`.`id` AS `id`, `a`.`name` AS `name`, `a`.`label` AS `label`, `a`.`description` AS `description`, `a`.`entity_name` AS `entity_name`, `a`.`items` AS `items`
FROM  a
ORDER BY `label` ASC
 [nativecode=1146 ** Table 'civicrmdb.a' doesn't exist].....

Any ideas? Stuck! Thanks in advance.

Edit after further research: CLI install command used:

cv core:install --cms-base-url="https://example.com" --lang="en_GB" --db="mysql://civicrmuser:password@localhost:3306/civicrmdb" -v

Result of cv:

{
    "srcPath": "/var/www/vhosts/example.com/httpdocs/vendor/civicrm/civicrm-core",
    "setupPath": "/var/www/vhosts/example.com/httpdocs/vendor/civicrm/civicrm-core/setup",
    "settingsPath": "/var/www/vhosts/example.com/httpdocs/web/sites/default/civicrm.settings.php",
    "templateCompilePath": "/var/www/vhosts/example.com/httpdocs/web/sites/default/files/civicrm/templates_c",
    "cms": "Drupal8",
    "cmsBaseUrl": "https://example.com",
    "db": {
        "server": "localhost:3306",
        "username": "civicrmuser",
        "password": "password",
        "database": "civicrmdb",
        "ssl_params": []
    },
    "cmsDb": {
        "server": "localhost:3306",
        "username": "drupaluser",
        "password": "password",
        "database": "drupaldb",
        "ssl_params": null
    },
    "siteKey": "mySiteKey",
    "credKeys": [
        "aes-cbc:hkdf-sha256:myCreds"
    ],
    "signKeys": [
        "jwt-hs256:hkdf-sha256:mySign"
    ],
    "loadGenerated": null,
    "lang": "en_GB",
    "components": [
        "CiviEvent",
        "CiviContribute",
        "CiviMember",
        "CiviMail",
        "CiviReport"
    ],
    "extensions": [
        "org.civicrm.search_kit"
    ],
    "paths": {
        "civicrm.files": {
            "url": "https://example.com/sites/default/files/civicrm",
            "path": "/var/www/vhosts/example.com/httpdocs/web/sites/default/files/civicrm"
        }
    },
    "settings": [],
    "mandatorySettings": [],
    "extras": []
}

Output from cv vars:show -

{
    "CIVI_CORE": "/var/www/vhosts/example.com/httpdocs/vendor/civicrm/civicrm-core/",
    "CIVI_DB_ARGS": "-h localhost -u civicrmdb -pcivicrmdb -P 3306 civicrmdb",
    "CIVI_DB_DSN": "mysql://civicrmuser:pass@localhost:3306/civicrmdb?new_link=true",
    "CIVI_DB_HOST": "localhost",
    "CIVI_DB_NAME": "civicrmdb",
    "CIVI_DB_PASS": "password",
    "CIVI_DB_PORT": 3306,
    "CIVI_DB_USER": "civicrmuser",
    "CIVI_FILES": "/var/www/vhosts/example.com/httpdocs/web/sites/default/files/civicrm/",
    "CIVI_LOG": "/var/www/vhosts/example.com/httpdocs/web/sites/default/files/civicrm/ConfigAndLog/CiviCRM.random.log",
    "CIVI_SETTINGS": "/var/www/vhosts/example.com/httpdocs/web/sites/default/civicrm.settings.php",
    "CIVI_SITE_KEY": "mySiteKey",
    "CIVI_TEMPLATEC": "/var/www/vhosts/example.com/httpdocs/web/sites/default/files/civicrm/templates_c/",
    "CIVI_UF": "Drupal8",
    "CIVI_URL": "https://example.com/libraries/civicrm/core/",
    "CIVI_VERSION": "5.52.2",
    "CMS_DB_ARGS": "-h localhost -u drupaluser -pdrupaldb -P 3306 drupaldb",
    "CMS_DB_DSN": "mysql://drupaluser:password@localhost:3306/drupaldb?new_link=true",
    "CMS_DB_HOST": "localhost",
    "CMS_DB_NAME": "drupaldb",
    "CMS_DB_PASS": "password",
    "CMS_DB_PORT": 3306,
    "CMS_DB_USER": "drupaluser",
    "CMS_ROOT": "/var/www/vhosts/example.com/httpdocs/web/",
    "CMS_URL": "https://example.com/",
    "CMS_VERSION": "9.4.5",
    "IS_INSTALLED": "1",
    "SITE_TYPE": "cv-auto"
}

Contents of vendor/civicrm... appears complete. Contents of web/libraries/civicrm... is definitely incomplete with hundreds of files missing including jquery etc which is obviously why it's no working.

Is the full core and packages required at /libraries/ or should CIVI_URL in cv be something else?

1
  • I followed all the installation instructions exactly. I am now trying to figure out why civicrm is looking in web/libraries for dependencies and not in vendor/civicrm/civicrm-packages?! I have installed the asset plugin. Or do I need to modify paths away from the default? Commented Aug 19, 2022 at 4:19

1 Answer 1

0

Did something fail during one of the composer commands at one point? You may need to run composer civicrm:publish manually then to copy files into web/libraries. For the DB Error, that error has come up before but shouldn't on a brand new install. Usually cv ext:upgrade will fix that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.