1

I'm using CiviCRM 4.6.5, Joomla 2.5.28 (yes, I know...), with 70k contacts and 25 groups (one of which is a smart group).

Since the upgrade to 4.5.6, contacts started to display the wrong groups (actually several times the same group, instead of several different groups). If you check the groups the contact should be in, the contact is there. But the group doesn't show on the contact record. Cleaning the Caches (through the backend) seems to fix the problem, and everything is fine and dandy for a while, with the groups displaying correctly in the contact records again. But the fix is only temporary - the next day, the problem is back again.

Can anyone please suggest where to start looking for the cause?

Thanks.

3

This sounds very much like https://issues.civicrm.org/jira/browse/CRM-16945

This has only just popped up in testing of 4.6 for my organisation as well.

2

Submitted the fix https://github.com/civicrm/civicrm-core/pull/6388 under CRM-16945

  • Thanks very much. This fix seems to cure the problem of duplicate groups appearing in the group list. But now, if you hard-add a contact to a smart group, then the group doesn't show up on the contact's Groups tab. Is this still part of the same issue? – Jern Aug 3 '15 at 12:13
  • Did you checked it inside "Smart Group" accordian (collapsible header just below group listing) ? Because only regular group is shown under Group Tab and smart group inside "Smart Group" accordian. Also the tab group count doesn't include smart group. – Monish Deb Aug 3 '15 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.