1

Smart groups that are based upon advanced search membership are broken after upgrade from 4.6.4 to 4.6.5. After the upgrade, the groups have everyone in the database. When you select contacts in group and then click on the edit smart group search criteria you get the advanced search form. The section for membership is expanded but the group is not selected nor is membership status filled in.

I can fix the groups but it's a bit of a pain.

I looked at the criteria in the civicrm_groups after the upgrade. It looks the same as before the upgrade and doesn't work. Once you manually fix them then the criteria is different. I'm not sure if the civicrm_membership_cache is messed up or if the criteria isn't getting update.

  • I have the same problem after going from 4.6.3 to 4.6.5. Once I tried the patch Monish supplied for the other issue, smart groups worked, but with the problem you describe, Paul. I gave up on it again when I realized the patch breaks our contact views, but I can help test or debug as needed. – Norris Jul 29 '15 at 5:25
  • I tried the patch but alas it didn't fix this issue. – Paul-Tahoe Jul 29 '15 at 17:15
1

It seems like a bug to me. Please raise a issue on Civicrm Issue tracker

  • Created Issue CRM-16938 for this – Paul-Tahoe Jul 29 '15 at 17:27
  • Paul I have submitted the PR. Please find the fix at CRM-16938 – Monish Deb Jul 30 '15 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.