2

I have been using the CiviContribute for a short while and it's quite good, but there is something that I could never make work.
Note: I use Civi on Wordpress.
In the Admin > Civicontribute > CiviContribute Component Settings, you can set the "Invoice Prefix" to whatever text you want, but when you go to the actual contribution in the dashboard and click View, the Invoice Number has the default prefix "INV_1".
Another example is: I used in the invoice template the {contribution.invoice_number} token and the same behavior, default prefix...
Does anyone have any experience with this or know a fix? Thanks a lot!

1 Answer 1

4

Welcome to CiviCRM SE.

The invoice number is stored for contribution at the time of creation. If you update the invoice prefix in contribute component settings it will not change the invoice number for the already created contribution but for the new ones it will use the new prefix.

You will need to do a bulk update on invoice numbers using mysql script or using api4 for the already created contributions.

HTH

Pradeep

1
  • YES! I can confirm that after adding the second contribution, both the Invoice number in the "View" window and the "{contribution.invoice_number}" in the exported PDF file now listen to the "Invoice Prefix" option. Thanks a lot, Pradeep!
    – Some Devs
    Oct 5, 2022 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.