I imported a large group of organisations into a sub-org group "Media". Some orgs had a specific generic addressee (ie, Editor) which I imported into the Custom Addressee field.

After import I noticed that any record that had a null value in Custom Addressee field now also had an Addressee field = "Customized" rather than the default Addressee tokens. This behavior seems a little odd but may be a product of how civi handles default field values that rely on tokens - guessing here.

I also tried to create a Profile that would allow me to bulk update the incorrect records. While it looked like I could select the default token string from the drop down list and civi seemed to be running the update nothing actually changed.

There are rather a lot of records to be going into each summary and changing them individually. Rather than doing a re-import and deferring import of Customs Addressee data until a subsequent import, I thought I would ask if anyone had a simple solution and/or an explanation for this behavior. Any assistance appreciated.

CiviCRM 4.4.10


1 Answer 1


I came across the same issue after upgrading a very old civicrm DB to latest (4.7.27)- i ran the following simple queries to reset to my default IDs (listed at civicrm/admin/options/addressee?reset=1 )

UPDATE civicrm_contact
SET addressee_id = 1
WHERE contact_type = 'Individual';

UPDATE civicrm_contact
SET addressee_id = 2
WHERE contact_type = 'Household';

UPDATE civicrm_contact
SET addressee_id = 3
WHERE contact_type = 'Organization';

I didn't need to retain any existing or "customized" but if one did, adding AND isnull(addressee_id) should work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.