0

Currently if you install Drupal 9, Drush then CiviCRM you end up with a Composer "Problem" due to Drush requiring consolidation/site-alias (^3.1.6 || ^4) and composer picking the v4 version which then requires consolidation/site-alias 4.0.0 requires symfony/filesystem (^5.4 || ^6)

1 Answer 1

2

The solution here is to either install CiviCRM before drush - or if installing on an existing site or if that fails you can help composer pick the right version

via composer require civicrm/civicrm-{core,packages,drupal-8}:"5.55.1" "consolidation/site-alias:^3.1.6" -W

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.