0

I have a CiviCRM (5.55.1) running on Drupal (9.4.8). The language ist set to German.

When I click "Neues Rundschreiben" aka "New Mailing", the URL of that menu item is https://MyHost/civicrm/a/#/mailing/new but then it redirects me to https://MyHost/de/civicrm/a/#/mailing/new. This give a Page not found error. If I remove the "de" from path, all works as expected.

This site does not use Mosaica and it does not have Multi-Language enabled.

It seems the only menu entry with this behavior.

Any Suggestion?

3
  • Are you in multilingual mode, or single-language German?
    – Aidan
    Nov 21, 2022 at 20:19
  • On a single language CiviCRM (5.50.4) and Multi-Language Drupal (9.4.8.) I do not experience any problems with or without the "de" in the path. If your problem persists maybe check your version of the mosaico extension and add it to the question as well.
    – Fabian
    Nov 22, 2022 at 9:50
  • This site does not use Mosaica and it does not have Multi-Language enabled.
    – Hershel
    Nov 27, 2022 at 18:49

1 Answer 1

1

We had a similar problem and could resolve it by disabling the language detection by url in Drupal: /admin/config/regional/language/detection

The reason however is most liekly a bug with Moasaico which saves the complete URL including Drupal's language prefix liek this: domain/prefix/url-path

Some "static files" CiviCRM/Mosaico uses can currently only be used if the urls are saved without the language prefix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.