1

I have installed CiviCRM on WordPress and it works well when I set the WordPress Address (URL) and Site Address (URL) as an internal IP address. enter image description here

After I replace both fields with my domain name, WordPress can still be reached and the login screen is shown. However, after logging in, the CiviCRM Home showed an incomplete page. Only "Access Keys:_" and the footer are shown with no menu on CiviCRM top. enter image description here

Can anyone help point me in the right direction about how to troubleshoot?

2 Answers 2

2

Can you also update the base URL in wp-content/uploads/civicrm/civicrm.settings.php

Find for CIVICRM_UF_BASEURL in the file and update the domain URL. Should be something below

define( 'CIVICRM_UF_BASEURL', 'http://www.domainname.org/');
1
  • I've replaced all IP address entries with domain names in the 'civicrm.settings.php' file and now it works like a charm. Thank you so much.
    – Oscar Liu
    Commented Nov 25, 2022 at 8:19
0

I installed wordpress and then via the Wordpress Settings --> General I changed WordPress Address (URL) and Site Address (URL) from http:localhost to my public address of, say, http:123.123.123.123. I could then publicly connect to my website and login to Wordpress admin. I then performed the installation of the CiviCRM plugin. This created the file civicrm.settings.php in my /srv/www/wordpress/wp-content/uploads/civicrm/ folder. The CiviCRM menu bar is displayed OK.

I then searched the civicrm.settings.php file for localhost and searched it for 123.123.123.123. The results were as follows:

administrator@wpserver:/srv/www/wordpress/wp-content/uploads/civicrm$ cat civicrm.settings.php | grep localhost
   define( 'CIVICRM_UF_DSN'   , 'mysql://wordpress:mypassword@localhost/wordpress?new_link=true');  
*      define( 'CIVICRM_DSN'         , 'mysql://cms:YOUR_PASSWORD@localhost/cms?new_link=true');  
*      define( 'CIVICRM_DSN'         , 'mysql://civicrm:YOUR_PASSWORD@localhost/civicrm?new_link=true');
    define('CIVICRM_DSN', 'mysql://wordpress:mypassword@localhost/wordpress?new_link=true');
   define('CIVICRM_DB_CACHE_HOST', 'localhost');

administrator@wpserver:/srv/www/wordpress/wp-content/uploads/civicrm$ cat civicrm.settings.php | grep 123.123.123.123
$civicrm_paths['wp.frontend.base']['url'] = 'http://123.123.123.123/'; 
$civicrm_paths['wp.backend.base']['url'] = 'http://123.123.123.123/wp-admin/'; 
$civicrm_setting['domain']['userFrameworkResourceURL'] = 'http://123.123.123.123/wp-content/plugins/civicrm/civicrm';
   define( 'CIVICRM_UF_BASEURL'      , 'http://123.123.123.123');

In summary 5 x localhost and 4 x 123.123.123.123.

I did the whole installation again but this time in a different order. I installed Wordpress, then installed the CiviCRM plugin, then logged in to Wordpress admin and in Wordpress Settings --> General I changed WordPress Address (URL) and Site Address (URL) from http:localhost to http:123.123.123.123. Now when I make a remote connection and login to Wordpress admin the CiviCRM Menu bar is not displayed.

If I search civicrm.settings.php then there are now 9 x localhost and no 123.123.123.123. Changing just the one setting as suggested above by Pradeep or changing all settings as Oscar suggested, does not solve the problem. Edit the civicrm.settings.php file and change localhost to 123.123.123.123 in the lines of code shown above. In my case, with Wordpress 6.2.2 and CiviCRM 5.61.3 these changes were at lines: 77, 78, 79, and 249.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.