2

I'm trying to set up the CiviMail return channel, and expect that, if I do it properly, headers like Reply-To and/or Return-Path will have values like bounces+verp-stuff@mydomain.com, but so far, that's not happening.

What I've done so far:

  1. Created an email account bounces@mydomain.com through Google Apps, and verified it receives an email sent to bounces+123@mydomain.com
  2. Edited the default mail account at /civicrm/admin/mailSettings?reset=1, with values (server, username, password, protocol, use ssl) that allow it to check email over IMAP on the bounces@mydomain.com and verified that some messages in that account get labeled with the inbox-civimail-ignored.
  3. Also at /civicrm/admin/mailSettings?reset=1, set "Email Domain" = "mydomain.com" and "Used For?" = "Bounce processing". Other fields in this form are blank.
  4. Outbound Email (/civicrm/admin/setting/smtp?reset=1) is set to "mail()"

I then create a new scheduled mailing and send it out using the "Send Scheduled Mailings" job, and the mail arrives with these headers:

Delivered-To: me@example.com
Received: by a.a.a.a with SMTP id x3csp113516itf;
        Wed, 29 Jul 2015 10:06:44 -0700 (PDT)
X-Received: by b.b.b.b with SMTP id o40mr63319942qga.0.1438189604113;
        Wed, 29 Jul 2015 10:06:44 -0700 (PDT)
Return-Path: <b.94.15.1ff1d88a496eafde@mydomain.com>
Received: from mydomain.com (mydomain.com. [c.c.c.c])
        by mx.google.com with ESMTP id g9si32260106qgf.41.2015.07.29.10.06.43
        for <me@example.com>;
        Wed, 29 Jul 2015 10:06:44 -0700 (PDT)
Received-SPF: pass (google.com: domain of b.94.15.1ff1d88a496eafde@mydomain.com designates c.c.c.c as permitted sender) client-ip=c.c.c.c;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of b.94.15.1ff1d88a496eafde@mydomain.com designates c.c.c.c as permitted sender) smtp.mail=b.94.15.1ff1d88a496eafde@mydomain.com
Received: by mydomain.com (Postfix, from userid 33)
    id D96011442D; Wed, 29 Jul 2015 17:06:43 +0000 (UTC)
To: Two Mice <me@example.com>
Subject: test 6fd
X-PHP-Originating-Script: 1001:mail.php
MIME-Version: 1.0
Content-Type: multipart/alternative;
 boundary="=_10b250b1b5a6af786cd9e0315548c9d9"
Reply-To: "My Site"
 <info@mydomain.com>
From: "My Site" <info@mydomain.com>
List-Unsubscribe: <mailto:u.94.15.1ff1d88a496eafde@mydomain.com>
job_id: 94
Precedence: bulk
X-CiviMail-Bounce: b.94.15.1ff1d88a496eafde@mydomain.com
Date: Wed, 29 Jul 2015 12:06:43 -0500
Message-Id: <20150729170643.D96011442D@mydomain.com>

--=_10b250b1b5a6af786cd9e0315548c9d9
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset=utf-8

Suspecting that our postfix setup might be messing with the headers, I set Outbound Email (/civicrm/admin/setting/smtp?reset=1) to "Redirect to Database", then created a new scheduled mailing and sent it out. The mail was stored in the civicrm_mailing_spool table with these headers:

MIME-Version: 1.0
Content-Type: multipart/alternative;
 boundary="=_6f3fb5f7026a6aecc8d6a73af912a390"
Reply-To: "My Site"
 <info@mydomain.com>
Return-Path: b.100.16.af889b4c23dd0331@mydomain.com
From: "My Site" <info@mydomain.com>
Subject: test 7
List-Unsubscribe: <mailto:u.100.16.af889b4c23dd0331@mydomain.com>
job_id: 100
To: Two Mice <me@example.com>
Precedence: bulk
X-CiviMail-Bounce: b.100.16.af889b4c23dd0331@mydomain.com | --=_6f3fb5f7026a6aecc8d6a73af912a390
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset=utf-8

Question: What else should I do to get bounces to be directed to my bounces@mydomain.com address?

1

In the Mail Accounts entry you set up, you need to set bounces+ as the localpart. Everything else looks good.

In your examples, you have b.94.15.1ff1d88a496eafde@mydomain.com as the return-path in the the first one and b.100.16.af889b4c23dd0331@mydomain.com in the second. CiviMail just needs to know to tack "bounces+" on the front of those addresses, and that's where the localpart comes in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.