2

Have already cleared cache several times and tried different browser.

This message appears twice in browser Console and menu won't load after update from 5.51 to 5.56 on D9. Menu was working before upgrade.

WARNING: Tried to load AngularJS more than once.
angular.js:15697 Error: [ng:btstrpd] http://errors.angularjs.org/1.8.2/ng/btstrpd?p0=%26lt%3Bcrm-angular-js%20modules%3D%22crmDashboard%22%26gt%3B
    at angular.js:99:1
    at c (angular.js:1944:13)
    at Object.Wc [as bootstrap] (angular.js:1984:12)
    at HTMLElement.<anonymous> (crm-angularjs-loader.js?r=HTcKBen_US:7:15)
    at Function.each (jquery.min.js:2:2903)
    at n.fn.init.each (jquery.min.js:2:846)
    at HTMLDocument.<anonymous> (crm-angularjs-loader.js?r=HTcKBen_US:6:52)
    at HTMLDocument.dispatch (jquery.min.js:3:12369)
    at r.handle (jquery.min.js:3:9088)
    at Object.trigger (jquery.min.js:3:11488)

This is the URL that is attempting to load:

https://www.site.org/libraries/civicrm/core/bower_components/angular/angular.js?r=oKGx5en_US

Settings

Image Directory: [civicrm.files]/persist/contribute/ Image Upload URL: [civicrm.files]/persist/contribute/ CiviCRM Resource URL: [cms.root]/libraries/civicrm/core

Thanks!

1 Answer 1

2

According to https://lab.civicrm.org/dev/core/-/issues/2975 there is one extra command to run after. Have created PR for documentation https://lab.civicrm.org/documentation/docs/sysadmin/-/merge_requests/347/diffs

composer civicrm:publish

2
  • But did that fix it for you? I had similar problems where this didn't help. Some older questions and answer suggested disabling asset caching, which did the trick. Jan 8, 2023 at 19:58
  • this did fix it for me, but disabling asset caching is a not a bad choice Jan 9, 2023 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.