0

This is a WordPress 6.1.1 site. During the upgrade from 5.46.3 to 5.57.3 (using cv), errors came up re table civicrm_search_segment not existing, as in this comment on issue: Upgrader - Apply extension updates after core updates. Tried running the extension database updates separately before or after with cv & eventually succeeded running these from the UI.

Table civicrm_search_segment was created but is empty. Before the upgrade there were about a dozen SearchKit saved searches, afterwards none show in the UI. Same result from multiple attempts.

Tried exporting a search from a copy of the pre-upgrade 5.46.3 site & importing into the upgraded 5.57.3 site. This failed with the following error displayed on the import dialog: Unsupported API action: only "save" is allowed.

Tried changing the API method in the pasted export code from "create" to "save", it then gave a different message: No records to import.

Any suggestions for how to restore the missing SearchKit searches?

1 Answer 1

1

The answer in this case turned out to be to update the Entity tables list extension from version 1.1 to 1.2 - the searches then reappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.