0

I'm seeing some issues with contact importing, and I wondered if anyone else is? Civi 5.58.0 on Wordpress with PHP 7.4

We have a process where we fairly regularly reimport existing contacts back into the system, using the contact update option to update the contents of custom fields, with data from a CSV file.

  • Attempting any import of individuals using First Name & Email supervised dedupe, even if only first name, last name and email is contained in the data results in all contacts failing with error "Mismatched contact type." I was initially seeing this bug: https://lab.civicrm.org/dev/core/-/issues/3927 but it is happening even when the update to a related contact is removed.

  • Attempting to import a list of individuals using first name & email unsupervised dedupe, and also trying to update a single custom field results in all imports failing with error "'1' is not a valid option for field custom_12" even though "1" is not a value contained anywhere in the CSV

  • So far as I can see, randomly one attempted import did "work", but the process erased the contents of some custom fields in Civi despite there being valid data in the CSV.

All was working fine before the recent security update - though the third item, where the import appeared to work, does obviously make me wonder if something is up with the server.

Thank you.

2 Answers 2

1

Looks like the first issue (Mismatched contact type) was to do with some stale data in the runner queue - removing those rows fixed the error.

The second error " "'1' is not a valid option for field custom_12"" is a bug, which is replicable on the demo site. When importing CSV data to a field with multiple possible defined answers (e.g. checkboxes), the import succeeds where multiple options are 'ticked' in the CSV file (i.e. an array) but fails where there is only 1 option ticked in the CSV. i.e.:

enter image description here

In the example above, the import of the second row fails with the error described.

1
  • Robin - we are getting the "Mismatched contact type" - when it makes no sense at all. how did you determine it was 'stale data'. it is happening for every single row in our import, so not much point removing them all and retrying :-)
    – petednz - fuzion
    Commented Aug 9, 2023 at 5:17
0

Robin - is it possible to replicate the issue on https://dmaster.demo.civicrm.org/ - we can investigate as a bug but need to be able to replicate it (also you should log a bug over on gitlab to track it)

1
  • Thanks, Eileen, I wonder if we have somehow picked up some corruption in our databases, as imports are also failing on another CiviCRM site on the same server, but with a different error "Cannot execute queue "user_job_8". The "civicrm_queue.runner" property is missing." I cannot replicate the error on the Demo site. Commented Feb 15, 2023 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.