1

CMS: Backdrop 1.24 CiviCRM: 5.58 PHP: 7.42 MySQL: 5.7.36 etc

I have a Backdrop/CiviCRM installation running without errors on MAMP.

I then tried to install CiviCRM with Backdrop on a live site hosted on a shared server, with a host that is known to support CiviCRM, but I cannot get CiviCRM to work. Installation goes fine, but when I start to try to go through the configuration checklist, I can load each link/form but cannot save any configuration changes I make.

The Backdrop admin menu includes a CiviCRM link, but selecting that does not load CiviCRM properly, no CiviCRM admin menu appears, and I get the following error message:

Unable to reach the server. Please refresh this page in your browser and try again.

CiviCRM tries to load via Ajax this: https://www.[site].com/CiviCRM/ajax/navmenu?code=ZQPw9lWA&locale=en_US&cid=3 and if I open that URL in a fresh tab, the JSON data is there, but the response code is 404. Therefore it doesn't work.

Base URL in CiviCRM.settings.php is https://www.[site].com Have also tried http instead of https and both with and without www.

I have tried with one database and with two (one for Backdrop and one for Civi). Same result.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.