0

I set my outbound email setting to SMTP. After that the server is not responsive anymore. After a long time I get a 504 Error "Gateway Timeout".

How can I retract that setting then, as my wordpress is not reachable anymore?

I can rename the civicrm folder in the WP plugin to deactivate the plugin in WP, but when renaming and activating the plugin again, I again get the 504 error - I guess because it again tries to do something with the SMTP server but it does not respond in time.

how can I reset the outbound email setting without access to the wordpress frontend?

cheers

1 Answer 1

2

I'm not sure why changing that would cause the problem you're seeing, but if you have command line access and have cv installed, you can run this to reset outbound mailing to the default:

$ cv api4 Setting.revert +s mailing_backend
1
  • 1
    The provider of the smtp-service insisted on an SSL connection. Apparently, this led to civiCRM wainting too long and thus getting unresponsive. The solution that worked for me (after resetting like described in this answer) was to add a ssl:// to the SMTP Server field in "Settings - Outbound Mail".
    – mplh
    Feb 23, 2023 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.