2

I believe we have a bug when search criteria includes a checkbox or multi-select fields (it may include other fields). I created a ticket: https://issues.civicrm.org/jira/browse/CRM-16947

  1. Create a multiselect custom field (or checkbox text)
  2. Search in advanced search and fails to pickup record
  3. Search in "find grant" and fails pickup record That's all I've tested but it fail be elsewhere too.
    Works in API and search builder.

I reproduced on the wordpress demo site (Contact-"Omar Barkley" custom field-"test contact") I Couldn't find a specific issue on Jira.

If it were only for contacts, I could use the search builder (which works) but This is for a grant. Need a select/checkbox for completing parts of a grant (status won't work.)

Has anyone else encountered this and/or resolved it?

3

I have fixed that under https://issues.civicrm.org/jira/browse/CRM-16927 and here's the PR https://github.com/civicrm/civicrm-core/pull/6342 (not merger yet). Can you please verify the patch if it works for ya ?

  • Ok, I will give it a try – Sonicthoughts Jul 31 '15 at 16:51
  • patch applied against 4.6.5 and it didn't seem to work. I'd have to clone and build a dev stack to test against master unless you can show me how to generate a patch against 4.6.5 for PR and affected files only. – Sonicthoughts Jul 31 '15 at 18:59
  • The PR is now merged, so you could just grab the latest code from github. – Coleman Aug 1 '15 at 14:51
  • A little help. using a beta/preproduction stack (not under git). usually i can just grab a .patch from GH and apply. This fails again as it is probably applied against master. Should i git clone -b 4.6.5 ? If so, do i need to do for drupal too? otherwise, how do i generate a patch against 4.6.5? – Sonicthoughts Aug 3 '15 at 15:18
  • Please check my comment on issues.civicrm.org/jira/browse/… of how to make/apply patch from PR. Ask me if if there is any doubt. – Monish Deb Aug 3 '15 at 15:27
0

I had two recent similar issues. One here (Advanced Search error after upgrade to 4.6.5) was resolved with a rc codebase that Eileen M kindly provided. The other (Different search results in Adv Search vs Search Builder), which is perhaps closer to yours, I temporarily resolved by going back down to 4.6.4. It sounds like a few search issues will be resolved when 4.6.6 comes out in a week or two.

You could try the new codebase that Eileen provided to see if that helps. If not, 4.6.6 is perhaps your best bet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.