1

After Drupal (9.5.3) and CiviCRM (5.58.1) updates last week, all versafix-based templates are just displaying a blank screen. I had also updated Mosaico to the latest, but reverting to the version in use last week hasn't helped.

The problem is that something is adding /en/ to the template path, but the files are in the folder without a language id.

The Drupal site is multilingual (to allow for webforms in different languages) but CiviCRM is not.

(GET https://secure.srigeneva.org/**en**/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/packages/mosaico/templates/versafix-1/template-versafix-1.html 404).

The file is where it says it should be, permissions 644.

https://secure.srigeneva.org/sites/default/files/civicrm/ext/uk.co.vedaconsulting.mosaico/packages/mosaico/templates/versafix-1/template-versafix-1.html

I can create new versafix templates, but not use them.

What works for today is to copy messages that worked last week and replace the contents, but several templates were created last week and not used so we can't pull them up.

Does anyone know how that /en is getting put into the path to the template?

Kathryn

2 Answers 2

2

Nothing else I could find worked so I totally removed and reinstalled Mosaico and can now use Versafix-1 to create and use new templates.

0

Check you extension url in Resource URL settings(CiviCRM >> System Settings >> Resource url)

6
  • It's set to [civicrm.files]/ext/. [civicrm_files] is correctly as secure.srigeneva.org/sites/default/files/civicrm
    – kathc
    Feb 22, 2023 at 16:19
  • Now that I'm looking for it, all of my CiviCRM pages are showing up with /en/ (I can take it out and they still appear, but clicking on any link goes to /en/civicrm/...
    – kathc
    Feb 22, 2023 at 16:50
  • I found another question that seems to have a similar problem so I'll try that solution. civicrm.stackexchange.com/a/38177/3596
    – kathc
    Feb 22, 2023 at 17:06
  • That didn't work, so I went back and removed and reinstalled Mosaico and it's working now (all of our recent new templates are still grey screen but we can make new ones. Hopefully this doesn't happen often because we've made a lot of templates to do system messages so it's a lot of wasted work every time.
    – kathc
    Mar 2, 2023 at 21:19
  • The new templates had the same issue shortly after posting above. I went back to Mosaico 2.9 and it's working again.
    – kathc
    Apr 9, 2023 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.