3

When using SearchKit and there are multiple profiles in the same row of the result, when I click on a to open a contact profile, sometimes an incorrect contact profile will open.

This happens using the link in the (List) Display Name column, and the profile that opens does seem to be that of another contact in the row. However, for some of the contacts the correct profile does open. Is this happening for anyone else?

Steps to re-produce in demo site:

  1. Create following search and click Search Search image 1

  2. Scroll to row where (Count) contact ID = 30, or you see multiple names in the (List) Display Name column

Search image 2

  1. Click Alexia Müller to try to open their profile (contact ID 157)

  2. It opens Kiara Jameson's profile (contact ID 42) enter image description here

  3. Repeat Steps 1-2 above search and try Mrs. Justina Jameson, it opens the correct profile.

  4. Note that some contacts in Display Name list are correct like [email protected] (https://dmaster.demo.civicrm.org/civicrm/contact/view?reset=1&cid=109) but the next contact in the list, [email protected], has the same link to the [email protected] contact .

1 Answer 1

2

It looks like the bug is triggered when you use "Distinct" mode for grouping. I'll take a look at what's going on there, but in the meantime you can disable "Distinct." When I did that, all the links pointed to the correct contact.

To disable it, open up "Field Transformations" and uncheck the box like this:

Distinct

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.