2

Since upgrading to 4.6.4 I get this error whenever trying to schedule a mailing:

A fatal error was triggered: is not of the type Int

And this error when trying to send a test mailing:

Error in call to Mailing_send_test : Error in call to MailingJob_create : A fatal error was triggered: is not of the type Int

This is on WordPress 4.2.4

  • 1
    This is a good question! To solve your problem, we'll need to see the expanded debugging information. In CiviCRM, please go to Administer menu > System Settings > Debugging and Error Handling, select "Yes" to both "Enable Debugging" and "Display Backtrace", and press "Save". Repeat the problem that caused your error, and you'll see much a much more detailed error. Please update this question with the expanded error and backtrace - and don't forget to disable debugging/backtrace when you're done! – Jon G - Megaphone Tech Aug 5 '15 at 14:29
  • I turned on both debugging and backtrace, then repeated the two processes. I received the same error messages, with no additional information beyond what I provided above.... – Eric Rogers Aug 5 '15 at 19:02
  • Hmm - I'm surprised you didn't see a backtrace - maybe it's hidden by your WP theme? You may want to check the ConfigAndLog directory for your CiviCRM log, which should hopefully include the backtrace, and post here. – Jon G - Megaphone Tech Aug 5 '15 at 19:14
3

There was a bug in CiviCRM 4.6.4 that triggered the same error 'A fatal error was triggered: is not of the type Int' when trying to rebuild the smart group cache so this could be related, especially if U used smart groups for your maling. I would suggest upgrading to 4.6.6 on a copy installation to see if that resolves the issue. Since this is not a real answer to your question I wanted to post this as a comment but I don't have sufficient reputation points to do that. I myself upgraded to 4.6.6 after experiencing too many problems with the 4.6.4 upgrade.

  • I think 'upgrade to 4.6.4 and confirm if the problem persists', is a valid answer but others may disagree – petednz - fuzion Aug 9 '15 at 23:58
0

I just report a bug that could be related Error on action "Email - schedule/send via CiviMail" with multiple event names filter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.