0

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: unknown error Return to home page.

There's nothing in the DB log.

I tried the Settings/Cleanup Caches and Update Paths/ panel doing both Cleanup Caches and Reset Paths, but to no avail.

This was from civi that was upgraded. I read that this can be caused by a problem when the database does not upgrade properly.

Since i didn't have much data, I did a fresh install, so a clean 5.94.4 and recreated custom fields, two profiles and two events.

When registering for the events i still get the same error on my clean install.

Backtrace gives me the following: CRM_Core_Exception: Could not find valid value for id in /home/mobility/public_html/administrator/components/com_civicrm/civicrm/CRM/Event/StateMachine/Registration.php on line 27

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. Could not find valid value for id

**** I did find this reference, seems this problem has been seen since 2015? CiviEvent - Error when registering: Could not find valid value for id

Are there any current solutions? My CiviEvent setup is quite vanilla. HELP!

9
  • perhaps you could see if you can replicate problem via a joomla demo site ie civicrm.org/…
    – petednz - fuzion
    Mar 30, 2023 at 23:48
  • Thanks for the reply. Joomla demo site i could not create custom fields and could not create a profile. I used what was there. Created an event, and price set.
    – Karen-Ann
    Mar 31, 2023 at 2:40
  • Thanks for the reply. I am using civi 5.59.4 fresh install. demo site is 5.58.0. Joomla demo site i could not create custom fields and could not create a profile. My event has alot i mean alot of custom fields in a profile. I use a price set. The preview of the price set i created looks as expected.
    – Karen-Ann
    Mar 31, 2023 at 2:46
  • On demo site i created an event using the price set i created. The price set does not show my first item in Event Link - Live. Note: on my event, that part is fine. On demo site i get the confirmation page, and then i get to paypal. This is what i expect/want. On my site, i get the error before i get to paypal (standard).
    – Karen-Ann
    Mar 31, 2023 at 2:48
  • i would welcome some help and will pay for it.
    – Karen-Ann
    Mar 31, 2023 at 2:48

3 Answers 3

1

I reduced the number of fields in the profile - I was at 40 and brought it down to 35. I had a big text block of Terms and Conditions with a "Do you accept the Terms & Conditions", with a "Yes" radio button as required field. and that was just too big. I just had a successful registration for our championship, from Hawaii no less!

1
  • well sleuthed - we hit a similar problem just yesterday and we are thinking about a PR to ensure that some appropriate "you may be adding too many fields to this fieldset" is added to the code. Actually in our case the problem was that the log table for the 'value' table had not added the extra columns, the fieldset itself was fine!
    – petednz - fuzion
    Mar 31, 2023 at 20:01
0

We encountered the same problem after the upgrade to CiviCRM version 5.62.1 on Joomla 3.10.11. Event registrations are impossible now. We didn't see this error in previous versions.

0

Are you using YOOtheme Pro? And its extension Essentials for YOOtheme by ZOOlanders?
Try deactivating the plugin: https://lab.civicrm.org/dev/core/-/issues/4394#note_92175

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.