1

The blue help bubble has stopped working on all my custom data fields. The error is shown in the snippet below, "Unable to load help file." Help for non-custom fields continues to work as usual. Clearing caches and resetting paths didn't help. At a loss for what else to do, I restarted the server to no avail. The CiviCRM log file records the exception in the text below the snippet.

CiviCRM 5.61.1, Drupal 7.97, MySQL 5.7.42, PHP 7.4.33

Custom field help error

May 18 20:36:16  [debug] $backTrace = #0 /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Error.php(443): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(39): CRM_Core_Error::handleUnhandledException(Object(RuntimeException))
#2 /home/civiprod/public_html/sites/all/modules/civicrm/drupal/civicrm.module(471): CRM_Core_Invoke::invoke((Array:3))
#3 /home/civiprod/public_html/includes/menu.inc(527): civicrm_invoke("ajax", "inline")
#4 /home/civiprod/public_html/index.php(21): menu_execute_active_handler()
#5 {main}


May 18 20:42:48  [error] 
$Fatal Error Details = array:3 [
  "message" => "Invalid {htxt} tag. Wrapped 0 opening-tags and 1 closing-tags."
  "code" => null
  "exception" => RuntimeException {#1347
    #message: "Invalid {htxt} tag. Wrapped 0 opening-tags and 1 closing-tags."
    #code: 0
    #file: "/home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Smarty/plugins/prefilter.htxtFilter.php"
    #line: 32
    trace: {
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Smarty/plugins/prefilter.htxtFilter.php:32 {
        smarty_prefilter_htxtFilter($tpl_source, &$smarty)
        › if ($htxts !== $_htxts) {
        ›   throw new \RuntimeException(sprintf('Invalid {htxt} tag. Wrapped %d opening-tags and %d closing-tags.', $htxts, $_htxts));
        › }
      }
      /home/civiprod/public_html/sites/all/modules/civicrm/packages/Smarty/Smarty_Compiler.class.php:248 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/packages/Smarty/Smarty.class.php:1499 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/packages/Smarty/Smarty.class.php:1432 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/packages/Smarty/Smarty.class.php:1271 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Smarty.php:192 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Page/Inline/Help.php:36 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Page/AJAX.php:59 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php:285 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php:69 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php:36 { …}
      /home/civiprod/public_html/sites/all/modules/civicrm/drupal/civicrm.module:471 { …}
      /home/civiprod/public_html/includes/menu.inc:527 { …}
      /home/civiprod/public_html/index.php:21 { …}
    }
  }
]


May 18 20:42:48  [debug] $backTrace = #0 /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Error.php(443): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /home/civiprod/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(39): CRM_Core_Error::handleUnhandledException(Object(RuntimeException))
#2 /home/civiprod/public_html/sites/all/modules/civicrm/drupal/civicrm.module(471): CRM_Core_Invoke::invoke((Array:3))
#3 /home/civiprod/public_html/includes/menu.inc(527): civicrm_invoke("ajax", "inline")
#4 /home/civiprod/public_html/index.php(21): menu_execute_active_handler()
#5 {main}

1 Answer 1

2

Looks like a regression to me, I can confirm it works on 5.58.1 but not dmaster, so not on the most recent version. I'd recommend posting an issue on Gitlab: https://lab.civicrm.org/groups/dev/-/issues

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.