1

By using TCPDF_FONTS::addTTFfont("/usr/share/fonts/truetype/droid/DroidSansFallbackFull.ttf", "TrueTypeUnicode");' I have successfully created the following three files droidsansfallbackfull.ctg.z, droidsansfallbackfull.z, and droidsansfallbackfull.php and copied into directory /var/www/html/wordpress/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom/tcpdf/fonts.

I have added the following $civicrm_setting['CiviCRM Preferences']['additional_fonts'] = 'droidsansfallbackfull'; in civicrm.settings.php. The characters have printed as square box, can someone please help, many thanks.

2 Answers 2

0

First, your setting needs to be an array:

`$civicrm_setting['CiviCRM Preferences']['additional_fonts'] = array('droidsansfallbackfull');

Then you'll need to actually set the font for the label at Administer - Communications - Label Formats. Edit the label type you're using and set the font in there.

2
  • Thanks, it works. The characters is showing what I expected, but the rest of the characters are showing as square box in the label. :( Commented May 24, 2023 at 11:20
  • Can you explain what "rest of characters" means?
    – Demerit
    Commented May 24, 2023 at 17:51
0

the rest of the characters are ordinary English characters. I did the same exercise again, but I use droidsansfallback instead of of droidsansfallbackFull, it is WORKING now, Thanks for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.