0

WP 6.2 civi 5.61.1 or 5.61.4 or 5.62.2 formcore 5.62.1 After upgrade to mosaico 2.12 could not edit existing templates. Console 404 errors. I tried: installing & uninstalling, changing resource url to absolute, asset cache on, off, auto, making ext directory 777, uninstalling civigrant

Now upgraded to civi 5.62.2 and mosaico 3.1.1687383640. Mosaico page and "new template" page images below. Selecting new template just hangs with "loading"

Civi log shows: Jun 27 15:37:40 [error] Afform error: cannot process ~/afsearchMosaicoTemplateList/afsearchMosaicoTemplateList.aff.html: malformed entity name ()

Browser console has 404 for https://website/wp-content/uploads/civicrm/ext/uk.co.vedaconsulting.mosaico-2.8/css/mosaico-bootstrap.css?r=0uwJ4en_US

full console error below

At wit's end really & boss wants newletter out yesterday!

enter image description here enter image description here [![enter image description here][3]][3]

2
  • You say you upgraded to Mosaico 3.1 but your errors show 2.8 in the path. Do you have both 2.8 & 3.1 files installed? I'd (save and) remove 2.8 files.
    – Aidan
    Jun 28, 2023 at 7:25
  • Yes I reverted to 2.8 in desperation. Don't have both installed.. errors are 404 in any version
    – LesleyJill
    Jun 28, 2023 at 20:00

2 Answers 2

1

Finally solved this. There was an .htaccess file in the wp-content/uploads/civicrm folder blocking all (direct) access to files in this directory. added below. Don't know how it got there - presume another extension?

content of file:

"<Files "*">

OpenLiteSpeed 1.4.38+

<IfModule !authz_core_module> RewriteRule .* - [F,L]

Apache 2.2

<IfModule !authz_core_module> Order allow,deny Deny from all

Apache 2.4+

Require all denied
0

You say you have a 404 error, so:

  • Is the file on the server where it's supposed to be?
  • Have you checked both the file permissions and ownership? Are they correct?

After that, you're getting into some weird scenarios, like web server misconfiguration. It may be worth looking at the HTTP response headers to see whether the 404 is coming from WordPress or the web server.

1
  • The fact that you're seeing this problem even when you revert strongly suggests a file permission/ownership issue. Jun 28, 2023 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.