1

We are running an old version of CiviCRM (5.3?) and we have planned to upgrade to a newer version and at the same time we planned to put CiviCRM in cloud. Our existing server is also old and seems to be not quite working recently. Is it true that we need to install the 5.3? version of CiviCRM (including the older version of PHP, MYSQL, and Wordpress) in the cloud first, import the data (created by MySqlDump) from the 5.3? version of CiviCRM into the newer version in cloud, then follow by the upgrade. OR create a new version of CiviCRM in the cloud and import the data over? I am new to CiviCRM, please give your advice and suggestions? Thanks

2 Answers 2

0

You don't have to install the old version in the cloud first, but you may have to go in small steps (e.g. maybe do 5.13, then 5.23, etc, just as examples), and you will have to first downgrade the cloud version of php to 7.2 until you get to closer the end.

3
  • Thanks for the reply. Is it you mean install the newer version of CiviCRM in the cloud - but NOT a hugh increase of version, and try to import the data from the older version? For PHP not use the latest version, try an older version? Thanks Jul 4, 2023 at 14:58
  • Yes exactly. You can try going straight to 5.62, but normally such a big jump fails. But maybe worth trying anyway.
    – Demerit
    Jul 4, 2023 at 15:16
  • I have tried to install 5.62 with no luck. It said critical error conatct .... The server is new just setup in Azure Jul 5, 2023 at 18:59
0

It depends on how dependent on your contact history you are and/or how many CiviCRM modules you use. We moved to the cloud (AWS Lightsail) last year. We are 'light' users. In 10 years on the old server, we had never used our contacts' history. So I installed the latest versions of everything. I re-created the old tags and groups and custom fields on the new server. Then I exported the contact data, tags, groups (as tags) and custom fields as CSV and imported the CSVs into the new server. No issues to date.

1
  • we are new to CiviCRM, we haven't used any modules. I have tried to install new version 5.62, it gave me errors. Jul 5, 2023 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.