1

Currently we have a SearchKit display to show activities on a case that are use to link to a form. Some activities are not showing as we expect on the final display.

As an example, there are currently a total of 13 activites on the SearchKit display that are appearing. However, on the case there are 16 activities. The three activities that are missing from the SearchKit display need to be visible to users.

On the preview of the search results, all 16 activities appear like we expect.. (see screenshot below) therefore the search is working however the display is not functioning as we expect.

Why aren't all 16 activities visible? Is there a limiter that I am not aware of, or is this potentially a bug?

Preview of search results:

enter image description here

SearchKit display:

enter image description here

Here is a Gist link to what the API call looks like

Here is a Gist link to the SQL

The search being carried out:

enter image description here

5
  • Suspicious that you have 13 dates in the search results. Is that correct (i.e. there are only 13 distinct dates)? Can you try without Distinct for the dates? Can you try changing one of the duplicate dates?
    – Lars SG
    Jul 20, 2023 at 13:45
  • It could also help to post a screenshot of the search itself and the SearchDisplay settings.
    – Lars SG
    Jul 20, 2023 at 13:45
  • I was going to suggest the same thing. Try removing DISTINCT from all of your field transformations.
    – Coleman
    Jul 21, 2023 at 2:14
  • Thanks Lars and Coleman. I removed Distinct from the Session date field transformation and this now makes all activities visible. However, I do not understand why! The original search works and returns all activities, including clickable links. It is the display that was the issue. I noticed that if I remove the link from the activity list then they all display as expected. Why would expressing the output as a link cause an issue? In my example, the dates happen to be the same but in production they are not. I would really like to understand this! Jul 21, 2023 at 9:14
  • I think it might help to figure out what's going on if you share a screenshot of the setup of the SearchDisplay (not the result of the SearchDisplay, but the screen that lists the columns and all the options).
    – Lars SG
    Jul 21, 2023 at 14:11

1 Answer 1

2

Lars and Coleman suggested the solution to this comment. Removing distinct from just the date on the activity session has solved the issue.

Search Query

See my comment above - I do not actually understand why this has solved the issue. Problem solved nevertheless! Thanks for your input.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.