2

Is anyone else experiencing this?

I upgraded to 5.64.0 and my page with a Contribution shortcode ([civicrm component="contribution" id="12" mode="live" hijack="0"]) generates a fatal Wordpress error. I confirmed that it works correctly under 5.63.1.

Wordpress sent the following information regarding the fatal eror. WordPress version 6.2.2 Active theme: Detroit Greenways (version 1.0) Current plugin: CiviCRM (version 5.64.0) PHP version 7.4.33

Error Details ============= An error of type E_ERROR was caused in line 1581 of the file /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/System/WordPress.php. Error message: Uncaught Error: Class 'Civi\Api4\ContributionPage' not found in /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/System/WordPress.php:1581 Stack trace: #0 /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component/Cms.php(142): CRM_Utils_System_WordPress->checkCleanurls() #1 /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check/Component.php(76): CRM_Utils_Check_Component_Cms::checkCleanurls(false) #2 /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check.php(215): CRM_Utils_Check_Component->checkAll(Array, false) #3 /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check.php(185): CRM_Utils_Check::checkStatus() #4 /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Check.php(93): CRM_Utils_Check::checkAll() #5 /home/detroi20/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Page.php(255): CRM_Utils_Check->showPeriodicAlerts() #6 /home/detroi20/public_html/wp-conte

1 Answer 1

2

5.64 moves a whole bunch of stuff into extensions and if the upgrade doesn't go smoothly there can be a mismatch between components and extensions. Check that both civicontribute component and the new extension are enabled.

1
  • Thanks. That got me to the solution. I looked at the extensions and the core components were all shown as not installed. I installed CiviContribute, but the Contribution page problem persisted. I disabled the CiviPledge component (still we don't use it) and then all the core component extensions were shown as installed -- and our contribute page worked again. It seems like changing the active components triggered something.
    – Todd Scott
    Aug 6, 2023 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.