2

This is a fresh install of a site which I've migrated data to from an outdated Drupal7/civi site we've used for years. I've installed Drupal-9 using Composer and civicrm (5.64) as well and am using php8.1 on a Ubuntu 22 Linode server. I installed ckeditor5 v1.5 downloaded from CiviCRM into ext folder and enabled through admin > settings > extensions. I then selected 'ckeditor5 with uploaded images (recommended)' from the display preferences. When I try to edit a mailing template by adding an image from the PC I'm working from, the image shows up in the editor but when I save, I get a saved alert but the image disappears. Any text or html changes persist. The image does not appear where I have set them. The upload directory is set to [civicrm.files]/persist/contribute/images/. I am working as the admin user. The image folder is owned by www-data:www-data with 775. I tried copying a .png file to the folder and pointing a browser to https://subdomain.siteimworkingon.org/sites/default/files/civicrm/persist/contribute/images/gbc.png it displays the image. If I use developer tools and watch Network tab while I am saving the template there is no obvious post errors or anything I can see. I've also tried summernote editor with similar results. I believe it must be a path or permission issue but I've reached the end of my troubleshooting skills. Any help will be much appreciated!

1
  • Anyone have an idea? Nov 2, 2023 at 10:11

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.