1

I am running Civicrm on Wordpress 6.3.1 and today I upgraded Civicrm from 5.58.1 to 5.65.1 successfully with no errors. Log output - [info] Running task: Finish core DB updates 5.65.1

I did notice some other warnings -

[warning] ManagedEntity update policy "unmodified" specified for entity type SearchDisplay which is not an APIv4 ManagedEntity. Falling back to policy "always"

[warning] \Symfony\Component\EventDispatcher\Event is deprecated. Consider using \Civi\Core\Event\GenericHookEvent. For more information see https://docs.civicrm.org/dev/en/latest/hooks/usage/symfony/#events Caller: Civi\FlexMailer\Validator::run]

[warning] Deprecated function CRM_Utils_Token::getTokenDetails, use If you hit this in mailing code you should use flexmailer - otherwise use the token processor. CRM_Core_Error::deprecatedFunctionWarning CRM_Utils_Token::getTokenDetails CRM_Mailing_BAO_MailingJob::deliverGroup CRM_Mailing_BAO_MailingJob::deliver Array ( [civi.tag] => deprecated )

///////////////////////////////////////////////////////////

I am not sure if my issues below is related to the above warnings.

#1. I was testing mailings after the upgrade I have noticed that the recipient field was empty (but showing the number of recipients {3 in this case} for a previous draft email). The error that I am getting is "Loading failed" when trying to select another group of recipients.

#2. I tried a new mailing and I get the same error "Loading failed" and am unable to select any group recipients.

In case #1 above the mail does get sent to the recipients.

I have attached a screen shot.

I am running Flexmailer.

Any help would be appreciated

Many Thanks

Error I am getting

1
  • Did you find a solution to this?
    – Jern
    Sep 26, 2023 at 7:47

3 Answers 3

1

It sounds like you may have a non-core version of Flexmailer in the mix (like Flexmailer 1.1.1 instead of Flexmailer 5.65). See this past question for instructions to remove.

Per the previous question, the steps are disable Mosaico, then Flexmailer. Delete the Flexmailer directory. Clear the caches. Enable the new Flexmailer, then Mosaico. Perform database upgrades if a message tells you to.

36
  • Thanks Lars SG....I did check and I noticed that I had Flexmailer 1.1.2 instead of Flexmailer 5.65....I have checked the past question for instructions....I have another problem as I am having problem installing command line interface to run cv commands....is there another way to update to Flexmailer 5.65 through UI?
    – markd
    Sep 13, 2023 at 12:37
  • I've added instructions to the answer above.
    – Lars SG
    Sep 13, 2023 at 13:21
  • Thanks @Lars My steps of what I did (Managed to get CLI working) From Extensions. Directory 1. copied flexmailer to different directory just in case I need it. 2. cv dis mosaico flexmailer 3. rm -rf org.civicrm.flexmailer when I did this, it did not remove the directory/contents so I used rm -rf flexmailer 4. cv flush 5. cv en flexmailer mosaico >>>>>error Extension cache does not contain requested item(s) Refreshing extension cache >>>Error: Unrecognized extension "flexmailer" I noticed in Adminster>System Settings>Extensions that FlexMailer was disabled and in red
    – markd
    Sep 14, 2023 at 7:26
  • I am now a little lost on what to do next as it is not picking up new Flexmailer but shows Flexmailer 1.1.2.
    – markd
    Sep 14, 2023 at 7:26
  • ...Would you suggest that I revert back to v5.58.1 as I have the files and database and then remove Fleximailer v1.1.2. Once this is done to upgrade the system to 5.65.1?
    – markd
    Sep 14, 2023 at 12:56
0

I have the same error since upgrading to 5.64.4 on one site (Joomla not WP). FlexMailer info.xml states it's 5.64.4 so not sure it's the same cause, but definitely the same 'loading failed' error in CiviMail.

The console gives me a 500 error on this URL when trying the lookup: https://www.---.org/administrator/?option=com_civicrm&task=civicrm/ajax/api4/EntitySet/autocomplete&params={"input":"","page":1,"formName":"crmMailing.479","fieldName":"Mailing.recipients_include"}&_=16951239190.

This makes it sound similar to this error: https://lab.civicrm.org/dev/core/-/issues/3587 - but I have other API4 calls working ok, it seems (e.g. contact lookup).

1
  • I did take a look and cannot reproduce. The only suggestions I have are what I am sure you've already done. Be sure o other flexmailer extensions are installed and flush all cv caches. Dec 4, 2023 at 22:51
0

I have had the same problem for the last few months. Flexmailer is up to date. I tried disabling it, but it's showing as "Required", and cv won't let me disable it either. Is this normal?

At the "Loading failed" error, the console shows a 500 error on GET https://domain.co.uk/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fajax%2Fapi4%2FEntitySet%2Fautocomplete&params=%7B%22input%22%3A%22%22%2C%22page%22%3A1%2C%22formName%22%3A%22crmMailing.628%22%2C%22fieldName%22%3A%22Mailing.recipients_include%22%7D&_=1695635330283

Any suggestions as to what could be causing this? Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.