1

I have just upgraded CiviCRM to v5.65.1 in my Joomla site (v4.3.4). Now, since that update I can no longer login to my admin backend - I get the following error displayed: 0 Class "Civi\Core\Container" not found

I have backed up the database files using the function in PHPMyAdmin, but need to rebuild the CiviCRM installation. Looking at the FTP backend, a lot of the CiviCRM files are zero bytes.

How do I restore my installation?

3
  • I am still trying to get access to my Joomla admin backend to sort this issue out. Can ANYONE here help? Sep 18, 2023 at 11:21
  • You could try deleting the files (perhaps, back them up first just in case, though not sure it'll be of any value), and FTP the appropriate directory/file trees from the unzipped CiviCRM download file into /administrator/components/com_civicrm and into /components/com_civicrm. Please make sure you reinstate backup copies of the /administrator/components/com_civicrm/civicrm_settings.php and /components/com_civicrm/civicrm_settings.php files. The Civi upgrade always overrides them for some odd reason. If you don't have backup copies, you could update the new files manually.
    – MtnPavlas
    Sep 19, 2023 at 12:12
  • See the comment I made yesterday for the solution to my issue. Sep 20, 2023 at 13:25

1 Answer 1

0

I asked this question on the Joomla forum and was told to set the enabled flag for the CiviCRM apps to zero within phpMyAdmin.

This did work and I was then able to apply the update that failed earlier to CiviCRM.

Maybe this is something that the developers should include in the documentation?

2
  • Checking I follow correctly: you tried to update (hopefully following docs.civicrm.org/sysadmin/en/latest/upgrade/joomla) but that resulted in zero-byte files and inability to log in. You disabled CiviCRM then updated again and it worked? I'm curious about those zero-byte files. Were you out of disk space?
    – Aidan
    Sep 19, 2023 at 11:52
  • No. I was not out of disk space. IONOS provide unlimited storage space. Previous CiviCRM updates have worked faultlessly. Sep 20, 2023 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.