0

I have created a submission form in FormBuilder, and initially referenced a holding page for the "post-submit page". However, when I have subsequently referenced a different post-submit page from FormBuilder, the updated post-submit page address remains visible on the configuration screen (even when the Formbuilder form is saved, closed and re-opened), but is ignored when a completed form is submitted (it uses the original holding page reference). I assume that this field in FormBuilder is not being read when the form is compiled at the point of saving it.

I can overcome the problem by cloning the form; when saved, the updated post-submit page works in the cloned version.

This would appear to be a bug, or am I missing something?

5
  • Just checking - you cleared the cache and force-reloaded the form in between?
    – Lars SG
    Commented Sep 14, 2023 at 15:08
  • I thought I had done so - but then I have tried it again and its working! How embarrassing but thank you! Commented Sep 15, 2023 at 13:44
  • I write from experience on this one!
    – Lars SG
    Commented Sep 15, 2023 at 14:13
  • This is frustrating. Having had some success, I now find the problem appearing again, across multiple devices and browsers, notwithstanding the clearing of cache and force reloading. I do think there is a problem here! Commented Sep 20, 2023 at 8:48
  • Try to replicate on dmaster.demo.civicrm.org ?
    – Lars SG
    Commented Sep 20, 2023 at 14:30

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.