2

After upgrading to Joomla 4.34 I cannot access the backend of my website.

My shared hosting account (Hostmonster) runs MySQL 5.7.23-23, which has limited me to CiviCRM 5.39 and running PHP 7.4. I've been looking into upgrading my hosting account to one that runs MySQL 5.7.5+ so that I can upgrade to the latest version of CiviCRM and use PHP 8+.

When I tried upgrading to PHP 8, I received this error: Sorry, there was a problem we could not recover from. The server returned a "500 - Whoops, looks like something went wrong."

Through file manager I set debug to "true" in the configuration.php file and received the below "Call stack" following the "An error has occurred. 0 Call to a member function register() on int" message.

I asked ChatGPT how to fix it and ChapGPT indicated that it was an issue with CiviCRM, but since I can't get into the backend, I can't try several of the solutions that were suggested.

I'm looking for options to gain access to the administration area of my website again. Once I do, I will upgrade my hosting account so that I can upgrade CiviCRM.

What do you suggest? Can I "Turn Off" the CIVICrm Component through file manager? Would that work?

Thanks,

Mike


"An error has occurred. 0 Call to a member function register() on int" message. Call stack

Function Location

1 () JROOT/administrator/components/com_civicrm/civicrm/CRM/Extension/ClassLoader.php:82 2 CRM_Extension_ClassLoader->register() JROOT/administrator/components/com_civicrm/civicrm/Civi/Core/Container.php:618 3 Civi\Core\Container::boot() JROOT/administrator/components/com_civicrm/civicrm/CRM/Core/Config.php:85 4 CRM_Core_Config::singleton() JROOT/plugins/user/civicrm/civicrm.php:109 5 plgUserCivicrm->civicrmResetNavigation() JROOT/plugins/user/civicrm/civicrm.php:91 6 plgUserCivicrm->onUserLogin() JROOT/libraries/src/Plugin/CMSPlugin.php:284 7 Joomla\CMS\Plugin\CMSPlugin->Joomla\CMS\Plugin{closure}() JROOT/libraries/vendor/joomla/event/src/Dispatcher.php:486 8 Joomla\Event\Dispatcher->dispatch() JROOT/libraries/src/Application/EventAware.php:111 9 Joomla\CMS\Application\WebApplication->triggerEvent() JROOT/libraries/src/Application/CMSApplication.php:866 10 Joomla\CMS\Application\CMSApplication->login() JROOT/libraries/src/Application/AdministratorApplication.php:341 11 Joomla\CMS\Application\AdministratorApplication->login() JROOT/administrator/components/com_login/src/Controller/DisplayController.php:82 12 Joomla\Component\Login\Administrator\Controller\DisplayController->login() JROOT/libraries/src/MVC/Controller/BaseController.php:678 13 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/libraries/src/Dispatcher/ComponentDispatcher.php:143 14 Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch() JROOT/administrator/components/com_login/src/Dispatcher/Dispatcher.php:45 15 Joomla\Component\Login\Administrator\Dispatcher\Dispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:361 16 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:143 17 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:186 18 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:293 19 Joomla\CMS\Application\CMSApplication->execute() JROOT/administrator/includes/app.php:61 20 require_once() JROOT/administrator/index.php:32

6
  • Just to clarify, the error occurred when you upgraded Joomla, and then got worse when you upgraded PHP, but you haven't recently upgrade Civi right? That's still 5.39?
    – Coleman
    Sep 19, 2023 at 20:39
  • Yes. I can't upgrade beyond 5.39 because my site runs on MySQL 5.7.23-23 and Civi 5.4+ requires MySQL 5.7.5+. docs.civicrm.org/installation/en/latest/general/requirements
    – Mike22359
    Sep 20, 2023 at 14:39
  • I am fairly sure my the issue began after the upgrade to Joomla 4.3.4. It was several days after upgrading that I attempted to access the backend of my site and ran into this problem.
    – Mike22359
    Sep 20, 2023 at 14:49
  • Have you cleared CiviCRM caches? Try deleting the contents of the templates_c directory.
    – Coleman
    Sep 20, 2023 at 16:36
  • That worked! Thank you, Coleman!
    – Mike22359
    Sep 20, 2023 at 19:46

1 Answer 1

2

You can fix this by clearing caches. Try one or both of the following:

  1. On the command line cd path/to/civicrm and then cv flush.
  2. Delete the contents of the templates_c directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.