1

Salut. I have all language files and databases in the right place, I can choose German in the language selector, but the menu and everything else stays English (even when I switched to single-language instead of multi-language system, with focus German). Also when I choose the option to prioritize the language from the CMS (Wordpress in German), it still displays in English. No problem before the upgrade to 5.65.2 What can I do? Thank you for any hints. enter image description here enter image description here

1 Answer 1

2

First message:


Possible solution - will be tested here - :

  • disable in the admin interface all except language EN
  • remove the installed language files in /l10n/ and /sql/
  • ... (to check what is inside the MySQL data base...)
  • install again using the extension " uplang ".

here what I have tested so far for the same problem:

CIVICRM: Same problem here for new installed

  • DRUPAL 10.1.5.
  • CIVICERM 5.66.0
  • Language files: Had been installed manually.
  • Configuration: "Language is inherited" from DRUPAL setting.

DRUPAL: All 4 languages working properly:

  • EN DE FR ES
  • Based on "Language Switcher" of DRUPAL.
    • (for CIVICRM: Same name. Not yet checked in detail.)

CIVICRM: Working fine for EN FR ES

  • If DE is selected, then CIVICRM continues to use the last language, e.g. EN FR ES.

CIVICRM: I installed in addition

  • then afterwards the version "German (Switzerland)". There was no corresponding additional checkbox then in the CVCRM admin interface for Localization.

CIVICRM: I installed uplang . So far no effect.

  • I tried several other possible solutions. So far no success.


second message - some hours later:



The problem has been settled.

Due to various configuration steps until the final success, the cause of the final success can not be identified reliably.

The probable success cause is:

  • I enabled "German (Switzerland)"
  • and I disabled: the language option just "German"

Besides this, the following configuration steps were tried, too:

  • Disable, enable both German variants in the list of optional languages.
  • Set for CIVICRM the German language to the "contact" language, then revert to the setting "inherit the CMS DRUPAL setting".

Software problem? And I played with other options. But the most probable success cause is: Setting to "German (Switzerland)". In both cases, the DRUPAL language switcher sets to /de/

So DRUPAL only knows 1 option for "de" and CIVICRM knows 2 options. This might be the reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.