0

I am trying to send out a Mosaico template on Civicrm. I have scheduled it on a certain day. However, I realise that the execution does not work. It is forever on the "Scheduled" state. I believe this has got to do something with the cron. Can anyone asssist me withi this please? enter image description here

3
  • as a stop gap have you tried running the Scheduled Job manually
    – petednz - fuzion
    Nov 1, 2023 at 18:40
  • ah - a colleague just wrote this "Looks like this is a civicrm bug which replicates when you create a reminder with an absolute date instead of a relative date. Eg this reminder was set for absolute date 30th October - I've fixed this in core. Please let me know if you notice any issues in the reminder. I'll then PR it to civi core for the community review"
    – petednz - fuzion
    Nov 1, 2023 at 19:05
  • I will see if i can dig out the fix and share with you if you are then able to test
    – petednz - fuzion
    Nov 1, 2023 at 19:05

2 Answers 2

1

Have you seen the documentation for setting up scheduled jobs? It looks complicated because there are several ways to set this up depending on your hosting environment. You will also find multiple similar questions on here.

1

Possibly related to the fix raised in this PR - https://github.com/civicrm/civicrm-core/pull/28105

Can you please try applying it any verify if it fixes your error? If yes, please comment on the PR.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.