0

I am using CiviCRM 5.64.2. A few days ago, I upgraded Joomla from version 4.3.0 to 4.4.0. Normally, I used to import a list of user data that I receive daily with a CSV file separated by semicolons using the 'Import Contacts' option. I did this for two days after the Joomla update. Today, I am unable to import with both the old and newly created CSV files. The process hangs at the screen as seen in the screenshot.

enter image description here

When I click the Retry button, nothing changes. When I click the Skip button, it terminates the process and does not import any data.

The data source, Mapping Steps, and Preview steps all look normal. However, when I click 'Import,' there is no progress in the 'Running Queue' screen. Previously, using this method, I could import 400-500 records at once, but now it won't import even a single one. I have also tried this on a different system with the same Joomla and CiviCRM versions, and the issue persists. I request your support to find a solution to this problem.

It could be related to the CiviCRM update, but there is an issue with the update. Detailed information about this problem can be found at Upgraded to Joomla 4, now unable to upgrade CiviCRM.

Information about the errors in the Error.Log file is also available at https://lab.civicrm.org/dev/joomla/-/issues/51#note_92343.

1 Answer 1

3

Below are the steps I followed to resolve this issue. These steps worked for me, and if there's no risk for you, you can try them as well.

Important: Before starting these procedures, be sure to take a complete backup. I perform backups via SSH using the command: for i in `cat /etc/trueuserowners | awk ' { print $1 } ' | tr -d :` ; do /scripts/pkgacct $i ; done When I need to restore, I enter the /home directory and use the command: /usr/local/cpanel/bin/restorepkg --skipaccount cpmove-joomla.tar.gz for restoration.

  1. First, download the latest CiviCRM version for Joomla, extract the ZIP file, and place it in the /tmp/ directory.
  2. Backup the files /components/com_civicrm/civicrm.settings.php and /administrator/components/com_civicrm/civicrm.settings.php to your computer.
  3. Rename the com_civicrm folder in the /components/ and /administrator/components/ directories to com_civicrm2 or any other name of your choice.
  4. Access Joomla > System > Extensions > Manage Extensions and disable all extensions related to CiviCRM (do not uninstall, just disable).
  5. Start the update from Joomla > System > Extensions > Install from Folder using the path /home/joomlaa/public_html/tmp/com_civicrm. After installation, you will receive an error message; please disregard it.
  6. Restore the backup copies of /components/com_civicrm/civicrm.settings.php and /administrator/components/com_civicrm/civicrm.settings.php to their respective locations.
  7. Delete everything under the /media/civicrm/templates_c path.
  8. Download the latest version of localization files and place them under /administrator/components/com_civicrm.
  9. Access Joomla > System > Extensions > Manage Extensions and re-enable all extensions related to CiviCRM (usually just CiviCRM).
  10. Refresh the page where you received the error in Step 5 and start the database update. This time, the database update will proceed without any PHP errors, and the installation will be completed smoothly.

After these steps, I didn't experience any data loss or configuration changes.

If everything is successful, you can use SSH commands rm -rf /home/joomla/public_html/components/com_civicrm2 and rm -rf /home/joomla/public_html/administrator/components/com_civicrm2 to delete the folders you renamed for backup purposes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.