1

I have recently upgraded multiple CRM instances to version 5.67.0 their respective latest versions, and I'm encountering a common issue with the Quick Search functionality in all of them. Before the upgrades, I could search for contacts by their phone numbers, and the search results would display the relevant contact's phone number and email address alongside their name. However, after the upgrades, when I perform a Quick Search using a phone number, the search results do not seem to be related to the input phone number at all. In fact, the results only display the contact's name, and these names are often incorrect.

Only the Phone option is active as a search option in quick search options. All other E-Mail, ID, External ID, etc. options are disabled.

enter image description here

This issue is affecting our ability to efficiently locate contacts in all of our CRM databases. I haven't made any changes to the CRM settings, so I believe this problem may be related to the recent upgrades to the respective CRM versions.

Could you please assist in resolving this common issue and provide guidance on how to restore the previous functionality of the Quick Search feature for phone numbers in multiple CRMs? Your support is greatly appreciated.

11
  • Hi Fatih. are you able to compare what you are seeing with one of the 'demo' sites (assuming there is a Joomla demo site on latest)
    – petednz - fuzion
    Commented Nov 7, 2023 at 18:03
  • Can you confirm that during your Civi upgrade you deleted all old files from the CiviCRM source code directory before replacing it with the new version?
    – Coleman
    Commented Nov 7, 2023 at 19:21
  • In search preferences (customise data & screens) , there is a setting to include email. Is this set to 'Yes' ? This got unset for one of my clients.
    – Andy Clark
    Commented Nov 8, 2023 at 9:00
  • Hello @petednz-fuzion I couldn't make a comparison because there is a "U_ILLEGAL_ARGUMENT_ERROR" error for J4 on cividemo.com. I think the issue might be related to my installation, as the same V4 version and the same CiviCRM version have the same problem on different sites with 5 different domain names. Commented Nov 8, 2023 at 20:20
  • Hello @Coleman I encountered an upgrade issue from CiviCRM 5.64.2 onwards. The J4 version kept throwing a continuous 500 error. Details of the installation steps I followed can be found at civicrm.stackexchange.com/a/45810/6848. If the question is about deleting all CiviCRM files in FTP, yes, the installation was done after everything was deleted. Commented Nov 8, 2023 at 20:26

2 Answers 2

2

Firstly, thank you for engaging with this troublesome issue. The fact that it occurred for some users and not others was truly meaningful. Today, I requested the users experiencing the issue to log in using an Incognito Tab. I observed that there were no issues. Therefore, clearing the Browser History resolved the problem. Thanks again.

0

I have the same errors and I am running civicrm 5.67.0 with drupal 9.5.11. I did not realize we were supposed to delete the source files first before upgrading - all these years and I have not been doing that. I am expecting you mean to delete the civicrm module and then use composer to require the new module ? What about the Vendor directory - are we supposed to delete anything there too?

BTW- I tried incognito in the FireFox browser with the same result - If I ask for a phone number, I get all 1,042 individuals listed vs. a single individual.

1
  • This would be better as a new Question - it is likely to be down voted as it does not seem to be an Answer
    – petednz - fuzion
    Commented Nov 14, 2023 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.